summaryrefslogtreecommitdiff
path: root/support/dependencies/check-host-tar.mk
diff options
context:
space:
mode:
Diffstat (limited to 'support/dependencies/check-host-tar.mk')
-rw-r--r--support/dependencies/check-host-tar.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/support/dependencies/check-host-tar.mk b/support/dependencies/check-host-tar.mk
new file mode 100644
index 000000000..010bde7a5
--- /dev/null
+++ b/support/dependencies/check-host-tar.mk
@@ -0,0 +1,9 @@
+TAR ?= tar
+
+ifeq (,$(call suitable-host-package,tar,$(TAR)))
+ DEPENDENCIES_HOST_PREREQ += host-tar
+ TAR = $(HOST_DIR)/usr/bin/tar
+endif
+
+# Since TAR is at least 1.17, it will certainly support --strip-components
+TAR_STRIP_COMPONENTS = --strip-components