summaryrefslogtreecommitdiff
path: root/target/cpio/cpioroot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/cpio/cpioroot.mk')
-rw-r--r--target/cpio/cpioroot.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
index b2b4c4951..42c5aecad 100644
--- a/target/cpio/cpioroot.mk
+++ b/target/cpio/cpioroot.mk
@@ -38,9 +38,13 @@ cpioroot-init:
$(CPIO_BASE): host-fakeroot makedevs cpioroot-init
-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+ifneq ($(BR2_HAVE_MANPAGES),y)
@rm -rf $(TARGET_DIR)/usr/man
+endif
+ifneq ($(BR2_HAVE_INFOPAGES),y)
@rm -rf $(TARGET_DIR)/usr/info
- -$(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
+endif
+ $(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
touch $(PROJECT_BUILD_DIR)/.fakeroot.00000