summaryrefslogtreecommitdiff
path: root/target/cpio/cpioroot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/cpio/cpioroot.mk')
-rw-r--r--target/cpio/cpioroot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
index d0c522545..b851f3c8d 100644
--- a/target/cpio/cpioroot.mk
+++ b/target/cpio/cpioroot.mk
@@ -55,7 +55,7 @@ endif
echo "chown -R 0:0 $(TARGET_DIR)" >> $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
- echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
+ echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
>> $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
endif
# Use fakeroot so tar believes the previous fakery