summaryrefslogtreecommitdiff
path: root/target/cpio
diff options
context:
space:
mode:
Diffstat (limited to 'target/cpio')
-rw-r--r--target/cpio/Config.in50
-rw-r--r--target/cpio/cpioroot.mk87
2 files changed, 0 insertions, 137 deletions
diff --git a/target/cpio/Config.in b/target/cpio/Config.in
deleted file mode 100644
index 83bdd21e0..000000000
--- a/target/cpio/Config.in
+++ /dev/null
@@ -1,50 +0,0 @@
-config BR2_TARGET_ROOTFS_CPIO
- bool "cpio the root filesystem"
- select BR2_HOST_FAKEROOT
- help
- Build a cpio archive of the root filesystem
-
-choice
- prompt "Compression method"
- default BR2_TARGET_ROOTFS_CPIO_NONE
- depends on BR2_TARGET_ROOTFS_CPIO
- help
- Select compressor for cpio filesystem of the root filesystem
-
-config BR2_TARGET_ROOTFS_CPIO_NONE
- bool "no compression"
- help
- Do not compress the cpio filesystem.
-
-config BR2_TARGET_ROOTFS_CPIO_GZIP
- bool "gzip"
- help
- Do compress the cpio filesystem with gzip.
- Note that you either have to have gzip installed on your host
- or select to build a gzip for your host. See the packages submenu.
-
-config BR2_TARGET_ROOTFS_CPIO_BZIP2
- bool "bzip2"
- help
- Do compress the cpio filesystem with bzip2.
- Note that you either have to have bzip2 installed on your host
- or select to build a bzip2 for your host. See the packages submenu.
-
-config BR2_TARGET_ROOTFS_CPIO_LZMA
- bool "lzma"
- help
- Do compress the cpio filesystem with lzma.
- Note that you either have to have lzma installed on your host
- or select to build a lzma for your host. See the packages submenu.
-
-endchoice
-
-config BR2_TARGET_ROOTFS_CPIO_COPYTO
- string "also copy the image to..."
- depends on BR2_TARGET_ROOTFS_CPIO
- default ""
- help
- Copies the resulting image to a secondary location
- like a tftp server's root directory.
-
- Example: $(IMAGE)-$(DATE).cpio$(CPIO_ROOTFS_COMPRESSOR_EXT)
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
deleted file mode 100644
index 2197d1050..000000000
--- a/target/cpio/cpioroot.mk
+++ /dev/null
@@ -1,87 +0,0 @@
-#############################################################
-#
-# cpio to archive target filesystem
-#
-#############################################################
-
-CPIO_BASE:=$(IMAGE).cpio
-
-CPIO_ROOTFS_COMPRESSOR:=
-CPIO_ROOTFS_COMPRESSOR_EXT:=
-CPIO_ROOTFS_COMPRESSOR_PREREQ:=
-ifeq ($(BR2_TARGET_ROOTFS_CPIO_GZIP),y)
-CPIO_ROOTFS_COMPRESSOR:=gzip -9 -c
-CPIO_ROOTFS_COMPRESSOR_EXT:=gz
-#CPIO_ROOTFS_COMPRESSOR_PREREQ:= gzip-host
-endif
-ifeq ($(BR2_TARGET_ROOTFS_CPIO_BZIP2),y)
-CPIO_ROOTFS_COMPRESSOR:=bzip2 -9 -c
-CPIO_ROOTFS_COMPRESSOR_EXT:=bz2
-#CPIO_ROOTFS_COMPRESSOR_PREREQ:= bzip2-host
-endif
-ifeq ($(BR2_TARGET_ROOTFS_CPIO_LZMA),y)
-CPIO_ROOTFS_COMPRESSOR:=lzma -9 -c
-CPIO_ROOTFS_COMPRESSOR_EXT:=lzma
-CPIO_ROOTFS_COMPRESSOR_PREREQ:= lzma-host
-endif
-
-ifneq ($(CPIO_ROOTFS_COMPRESSOR),)
-CPIO_TARGET := $(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT)
-else
-CPIO_TARGET := $(CPIO_BASE)
-endif
-
-ROOTFS_CPIO_COPYTO:=$(call qstrip,$(BR2_TARGET_ROOTFS_CPIO_COPYTO))
-#
-
-cpioroot-init:
- rm -f $(TARGET_DIR)/init
- ln -s sbin/init $(TARGET_DIR)/init
-
-$(CPIO_BASE): host-fakeroot makedevs cpioroot-init
- # Use fakeroot to pretend all target binaries are owned by root
- rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
- touch $(BUILD_DIR)/.fakeroot.00000
- cat $(BUILD_DIR)/.fakeroot* > $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
- echo "chown -R 0:0 $(TARGET_DIR)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
-ifneq ($(TARGET_DEVICE_TABLE),)
- # Use fakeroot to pretend to create all needed device nodes
- echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
- >> $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
-endif
- # Use fakeroot so tar believes the previous fakery
- echo "cd $(TARGET_DIR) && find . | cpio --quiet -o -H newc > $(CPIO_BASE)" \
- >> $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
- chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
- $(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
- #-@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
-ifeq ($(CPIO_ROOTFS_COMPRESSOR),)
-ifneq ($(ROOTFS_CPIO_COPYTO),)
- $(Q)cp -f $(CPIO_BASE) $(ROOTFS_CPIO_COPYTO)
-endif
-endif
-
-ifneq ($(CPIO_ROOTFS_COMPRESSOR),)
-$(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT): $(CPIO_ROOTFS_COMPRESSOR_PREREQ) $(CPIO_BASE)
- $(CPIO_ROOTFS_COMPRESSOR) $(CPIO_BASE) > $(CPIO_TARGET)
-ifneq ($(ROOTFS_CPIO_COPYTO),)
- $(Q)cp -f $(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT) $(ROOTFS_CPIO_COPYTO).$(CPIO_ROOTFS_COMPRESSOR_EXT)
-endif
-endif
-
-cpioroot: $(CPIO_TARGET)
-
-cpioroot-source:
-
-cpioroot-clean:
-
-cpioroot-dirclean:
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_ROOTFS_CPIO),y)
-TARGETS+=cpioroot
-endif