summaryrefslogtreecommitdiff
path: root/target/cramfs/cramfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/cramfs/cramfs.mk')
-rw-r--r--target/cramfs/cramfs.mk31
1 files changed, 5 insertions, 26 deletions
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index f43162905..ccd316f5d 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -13,31 +13,10 @@ ifneq ($(TARGET_DEVICE_TABLE),)
CRAMFS_OPTS += -D $(TARGET_DEVICE_TABLE)
endif
-CRAMFS_TARGET=$(IMAGE).cramfs
+define ROOTFS_CRAMFS_CMD
+ $(HOST_DIR)/usr/bin/mkcramfs -q $(CRAMFS_OPTS) $(TARGET_DIR) $$@
+endef
-cramfsroot: host-fakeroot host-cramfs makedevs
- # Use fakeroot to pretend all target binaries are owned by root
- rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
- touch $(BUILD_DIR)/.fakeroot.00000
- cat $(BUILD_DIR)/.fakeroot* > $(BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
- echo "chown -R 0:0 $(TARGET_DIR)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
-ifneq ($(TARGET_DEVICE_TABLE),)
- # Use fakeroot to pretend to create all needed device nodes
- echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
- >> $(BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
-endif
- # Use fakeroot so mkcramfs believes the previous fakery
- echo "$(HOST_DIR)/usr/bin/mkcramfs -q $(CRAMFS_OPTS) " \
- "$(TARGET_DIR) $(CRAMFS_TARGET)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
- chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
- $(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
- -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
+ROOTFS_CRAMFS_DEPENDENCIES = host-cramfs
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_ROOTFS_CRAMFS),y)
-TARGETS+=cramfsroot
-endif
+$(eval $(call ROOTFS_TARGET,cramfs)) \ No newline at end of file