summaryrefslogtreecommitdiff
path: root/target/device/Atmel
diff options
context:
space:
mode:
Diffstat (limited to 'target/device/Atmel')
-rw-r--r--target/device/Atmel/DataFlashBoot/DataflashBoot.mk5
-rw-r--r--target/device/Atmel/Makefile.in22
-rw-r--r--target/device/Atmel/at91bootstrap/at91bootstrap.mk2
-rw-r--r--target/device/Atmel/atngw100-base/Makefile.in2
-rw-r--r--target/device/Atmel/atngw100-expanded/Makefile.in2
-rw-r--r--target/device/Atmel/atngw100/Makefile.in2
-rw-r--r--target/device/Atmel/u-boot/u-boot.mk2
7 files changed, 19 insertions, 18 deletions
diff --git a/target/device/Atmel/DataFlashBoot/DataflashBoot.mk b/target/device/Atmel/DataFlashBoot/DataflashBoot.mk
index 23930a330..0a2ffcbbc 100644
--- a/target/device/Atmel/DataFlashBoot/DataflashBoot.mk
+++ b/target/device/Atmel/DataFlashBoot/DataflashBoot.mk
@@ -5,7 +5,8 @@
#############################################################
DATAFLASHBOOT_VERSION:=1.05
DATAFLASHBOOT_NAME:=DataflashBoot-$(DATAFLASHBOOT_VERSION)
-ATMEL_MIRROR:=$(strip $(subst ",, $(BR2_ATMEL_MIRROR)))
+ATMEL_MIRROR:=$(strip $(subst ",, $(BR2_ATMEL_MIRROR)))
+# "))
DATAFLASHBOOT_SITE:=$(ATMEL_MIRROR)/Source
DATAFLASHBOOT_SOURCE:=$(DATAFLASHBOOT_NAME).tar.bz2
DATAFLASHBOOT_DIR:=$(PROJECT_BUILD_DIR)/$(DATAFLASHBOOT_NAME)
@@ -42,6 +43,6 @@ endif
# Toplevel Makefile options
#
#############################################################
-ifeq ($(strip $(BR2_TARGET_DATAFLASHBOOT)),y)
+ifeq ($(BR2_TARGET_DATAFLASHBOOT),y)
TARGETS+=dataflash
endif
diff --git a/target/device/Atmel/Makefile.in b/target/device/Atmel/Makefile.in
index 8ad35c62c..117a7c252 100644
--- a/target/device/Atmel/Makefile.in
+++ b/target/device/Atmel/Makefile.in
@@ -1,11 +1,11 @@
# *******************************************************************
-ifeq ($(strip $(BR2_TARGET_ATMEL)),y)
+ifeq ($(BR2_TARGET_ATMEL),y)
ATMEL_PATH:=target/device/Atmel
-BOARD_NAME:=$(strip $(subst ",, $(BR2_BOARD_NAME)))
+BOARD_NAME:=$(strip $(subst ",, $(BR2_BOARD_NAME)))
#"))
-BOARD_PATH:=$(strip $(subst ",, $(BR2_BOARD_PATH)))
+BOARD_PATH:=$(strip $(subst ",, $(BR2_BOARD_PATH)))
#"))
ATMEL_TARGET:=$(ATMEL_PATH)/root
@@ -13,22 +13,22 @@ TARGET_SKELETON:=$(ATMEL_TARGET)/target_skeleton
TARGET_DEVICE_TABLE:=$(ATMEL_TARGET)/device_table.txt
TARGET_SKELETON_LINKS:=$(ATMEL_TARGET)/skel.tar.gz
-TARGET_ATMEL_COPYTO:=$(strip $(subst ",, $(BR2_TARGET_ATMEL_COPYTO)))
+TARGET_ATMEL_COPYTO:=$(strip $(subst ",, $(BR2_TARGET_ATMEL_COPYTO)))
# These are set by Config.in
-DOWNLOAD_LINUX26_VERSION:=$(strip $(subst ",, $(BR2_DOWNLOAD_LINUX26_VERSION)))
+DOWNLOAD_LINUX26_VERSION:= $(strip $(subst ",, $(BR2_DOWNLOAD_LINUX26_VERSION)))
#"))
ifeq ($(DOWNLOAD_LINUX26_VERSION),)
DOWNLOAD_LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
endif
-LINUX26_VERSION:=$(strip $(subst ",, $(BR2_LINUX26_VERSION)))
+LINUX26_VERSION:=$(strip $(subst ",, $(BR2_LINUX26_VERSION)))
#"))
ifeq ($(LINUX26_VERSION),)
LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
endif
-LINUX26_RC_PATCH:=$(strip $(subst ",, $(BR2_LINUX26_RC_PATCH)))
+LINUX26_RC_PATCH:=$(strip $(subst ",, $(BR2_LINUX26_RC_PATCH)))
#"))
# These are set by "new" Config.in
@@ -39,7 +39,7 @@ LINUX26_BUILD_DIR:=$(PROJECT_BUILD_DIR)
#LINUX26_BINLOC=$(LINUX26_FORMAT)
#LINUX26_BINLOC:=$(BINARIES_DIR)/$(LINUX26_KERNEL)
-ifeq ($(strip $(BR2_avr32)),y)
+ifeq ($(BR2_avr32),y)
LINUX26_BINLOC:=arch/$(KERNEL_ARCH)/boot/images/$(BR2_PACKAGE_LINUX_FORMAT)
endif
@@ -63,15 +63,15 @@ include target/device/Atmel/*/Makefile.in
UBOOT_CONFIG:=$(UBOOT_BOARD_NAME)_config
UBOOT_CONFIG_FILE:=$(BOARD_PATH)/u-boot/$(UBOOT_BOARD_NAME).h
-ifeq ($(strip $(BR2_TARGET_UBOOT_AT91)),y)
+ifeq ($(BR2_TARGET_UBOOT_AT91),y)
include $(ATMEL_PATH)/u-boot/u-boot.mk
endif
-ifeq ($(strip $(BR2_TARGET_DATAFLASHBOOT)),y)
+ifeq ($(BR2_TARGET_DATAFLASHBOOT),y)
include $(ATMEL_PATH)/DataFlashBoot/DataflashBoot.mk
endif
-ifeq ($(strip $(BR2_TARGET_AT91BOOTSTRAP)),y)
+ifeq ($(BR2_TARGET_AT91BOOTSTRAP),y)
include $(ATMEL_PATH)/at91bootstrap/at91bootstrap.mk
endif
diff --git a/target/device/Atmel/at91bootstrap/at91bootstrap.mk b/target/device/Atmel/at91bootstrap/at91bootstrap.mk
index 66558107d..facee12f3 100644
--- a/target/device/Atmel/at91bootstrap/at91bootstrap.mk
+++ b/target/device/Atmel/at91bootstrap/at91bootstrap.mk
@@ -86,6 +86,6 @@ at91bootstrap-dirclean:
# Toplevel Makefile options
#
#############################################################
-ifeq ($(strip $(BR2_TARGET_AT91BOOTSTRAP)),y)
+ifeq ($(BR2_TARGET_AT91BOOTSTRAP),y)
TARGETS+=at91bootstrap
endif
diff --git a/target/device/Atmel/atngw100-base/Makefile.in b/target/device/Atmel/atngw100-base/Makefile.in
index 5af1ebf9a..c80a0bc2c 100644
--- a/target/device/Atmel/atngw100-base/Makefile.in
+++ b/target/device/Atmel/atngw100-base/Makefile.in
@@ -1,4 +1,4 @@
-ifeq ($(strip $(BR2_TARGET_AVR32_ATNGW100_BASE)),y)
+ifeq ($(BR2_TARGET_AVR32_ATNGW100_BASE),y)
ATNGW100_BASE_PATH=target/device/Atmel/atngw100-base
TARGET_SKELETON=$(ATNGW100_BASE_PATH)/target_skeleton
diff --git a/target/device/Atmel/atngw100-expanded/Makefile.in b/target/device/Atmel/atngw100-expanded/Makefile.in
index f7cb822ae..7ea35e02e 100644
--- a/target/device/Atmel/atngw100-expanded/Makefile.in
+++ b/target/device/Atmel/atngw100-expanded/Makefile.in
@@ -1,4 +1,4 @@
-ifeq ($(strip $(BR2_TARGET_AVR32_ATNGW100_EXPANDED)),y)
+ifeq ($(BR2_TARGET_AVR32_ATNGW100_EXPANDED),y)
ATNGW100_EXPANDED_PATH=target/device/Atmel/atngw100-expanded
TARGET_SKELETON=$(ATNGW100_EXPANDED_PATH)/target_skeleton
diff --git a/target/device/Atmel/atngw100/Makefile.in b/target/device/Atmel/atngw100/Makefile.in
index 165a2513f..cd506e9e3 100644
--- a/target/device/Atmel/atngw100/Makefile.in
+++ b/target/device/Atmel/atngw100/Makefile.in
@@ -1,4 +1,4 @@
-ifeq ($(strip $(BR2_TARGET_AVR32_ATNGW100)),y)
+ifeq ($(BR2_TARGET_AVR32_ATNGW100),y)
ATNGW100_PATH=target/device/Atmel/atngw100
TARGET_SKELETON=$(ATNGW100_PATH)/target_skeleton
diff --git a/target/device/Atmel/u-boot/u-boot.mk b/target/device/Atmel/u-boot/u-boot.mk
index 0096337a2..cf7b974f1 100644
--- a/target/device/Atmel/u-boot/u-boot.mk
+++ b/target/device/Atmel/u-boot/u-boot.mk
@@ -247,7 +247,7 @@ ubootroot-dirclean:
# Toplevel Makefile options
#
#############################################################
-ifeq ($(strip $(BR2_TARGET_UBOOT_AT91)),y)
+ifeq ($(BR2_TARGET_UBOOT_AT91),y)
TARGETS+=uboot
endif