summaryrefslogtreecommitdiff
path: root/target/device/x86/i386/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'target/device/x86/i386/Makefile.in')
-rw-r--r--target/device/x86/i386/Makefile.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/target/device/x86/i386/Makefile.in b/target/device/x86/i386/Makefile.in
index 876304b7e..08ae1b1a2 100644
--- a/target/device/x86/i386/Makefile.in
+++ b/target/device/x86/i386/Makefile.in
@@ -1,7 +1,17 @@
BR2_BOARD_PATH:=target/device/x86/i386
+ifeq ($(strip $(BR2_PACKAGE_LINUX_KCONFIG)),)
ifndef LINUX26_KCONFIG
LINUX26_KCONFIG=$(BR2_BOARD_PATH)/linux26.config
endif
-LINUX26_FORMAT=bzImage
+else
+LINUX26_KCONFIG=$(strip $(BR2_PACKAGE_LINUX_KCONFIG))
+endif
+ifeq ($(strip $(BR2_PACKAGE_LINUX_FORMAT)),)
+ifndef LINUX26_FORMAT
+LINUX26_FORMAT=bzImage
+endif
+else
+LINUX26_FORMAT=$(strip $(BR2_PACKAGE_LINUX_FORMAT))
+endif