summaryrefslogtreecommitdiff
path: root/target/ext2/ext2root.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/ext2/ext2root.mk')
-rw-r--r--target/ext2/ext2root.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index fd0016df8..779ffd9bb 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -98,7 +98,7 @@ endif
@test -d $(TARGET_DIR)/usr/share && \
rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share || \
true
- $(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
+ $(if $(TARGET_LDCONFIG),test -x $(TARGET_LDCONFIG) && $(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null)
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
touch $(PROJECT_BUILD_DIR)/.fakeroot.00000