summaryrefslogtreecommitdiff
path: root/target/ext2
diff options
context:
space:
mode:
Diffstat (limited to 'target/ext2')
-rw-r--r--target/ext2/ext2root.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index 5f9a59bb2..82912df5c 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -97,9 +97,11 @@ $(EXT2_BASE): host-fakeroot makedevs genext2fs
touch $(STAGING_DIR)/.fakeroot.00000
cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
+ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
>> $(STAGING_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))
+endif
# Use fakeroot so genext2fs believes the previous fakery
ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)),0)
GENEXT2_REALSIZE=`LC_ALL=C du -l -s -c -k $(TARGET_DIR) | grep total | sed -e "s/total//"`; \