summaryrefslogtreecommitdiff
path: root/target/ext2
diff options
context:
space:
mode:
Diffstat (limited to 'target/ext2')
-rw-r--r--target/ext2/ext2root.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index 08a407eab..4ebb98142 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -91,7 +91,8 @@ $(EXT2_BASE): host-fakeroot makedevs genext2fs
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/share/man
@rm -rf $(TARGET_DIR)/usr/info
- @rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
+ @test -d $(TARGET_DIR)/usr/share && \
+ rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
-/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))