summaryrefslogtreecommitdiff
path: root/target/generic/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'target/generic/Makefile.in')
-rw-r--r--target/generic/Makefile.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/generic/Makefile.in b/target/generic/Makefile.in
index 4ea0b6a6b..3541264c8 100644
--- a/target/generic/Makefile.in
+++ b/target/generic/Makefile.in
@@ -7,3 +7,15 @@ TARGET_SKELETON=target/generic/target_busybox_skeleton
TARGET_DEVICE_TABLE=target/generic/mini_device_table.txt
endif
+TARGET_GENERIC_GETTY:=$(strip $(subst ",, $(BR2_TARGET_GENERIC_GETTY_PORT)))
+#"))
+TARGET_GENERIC_GETTY_BAUDRATE:=$(strip $(subst ",, $(BR2_TARGET_GENERIC_GETTY_BAUDRATE)))
+#"))
+
+target-generic-getty:
+ $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
+ $(TARGET_DIR)/etc/inittab
+
+ifeq ($(BR2_TARGET_GENERIC_GETTY),y)
+TARGETS += target-generic-getty
+endif