summaryrefslogtreecommitdiff
path: root/target/squashfs/squashfsroot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/squashfs/squashfsroot.mk')
-rw-r--r--target/squashfs/squashfsroot.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index 8e6166e77..3fbdf9a4f 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -45,8 +45,12 @@ SQUASHFS_TARGET:=$(IMAGE).squashfs
squashfsroot: host-fakeroot makedevs squashfs
-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+ifneq ($(BR2_HAVE_MANPAGES),y)
@rm -rf $(TARGET_DIR)/usr/man
+endif
+ifneq ($(BR2_HAVE_INFOPAGES),y)
@rm -rf $(TARGET_DIR)/usr/info
+endif
$(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(SQUASHFS_TARGET))