summaryrefslogtreecommitdiff
path: root/target/ubifs
diff options
context:
space:
mode:
Diffstat (limited to 'target/ubifs')
-rw-r--r--target/ubifs/Config.in5
-rw-r--r--target/ubifs/ubifsroot.mk2
2 files changed, 0 insertions, 7 deletions
diff --git a/target/ubifs/Config.in b/target/ubifs/Config.in
index 85229f61c..90ebfd9e4 100644
--- a/target/ubifs/Config.in
+++ b/target/ubifs/Config.in
@@ -23,11 +23,6 @@ config BR2_TARGET_ROOTFS_UBIFS_MAXLEBCNT
help
Some comment required here
-config BR2_TARGET_ROOTFS_UBIFS_SQUASH
- bool "Make all files be owned by root"
- depends on BR2_TARGET_ROOTFS_UBIFS
- default y
-
config BR2_TARGET_ROOTFS_UBIFS_OUTPUT
string "Output File"
depends on BR2_TARGET_ROOTFS_UBIFS
diff --git a/target/ubifs/ubifsroot.mk b/target/ubifs/ubifsroot.mk
index cd330df01..2f3e96505 100644
--- a/target/ubifs/ubifsroot.mk
+++ b/target/ubifs/ubifsroot.mk
@@ -93,9 +93,7 @@ endif
rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
touch $(PROJECT_BUILD_DIR)/.fakeroot.00000
cat $(PROJECT_BUILD_DIR)/.fakeroot* > $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
-ifneq ($(BR2_TARGET_ROOTFS_UBIFS_SQUASH),)
echo "chown -R 0:0 $(TARGET_DIR)" >> $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
-endif
ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \