summaryrefslogtreecommitdiff
path: root/toolchain/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/Makefile.in')
-rw-r--r--toolchain/Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 1a2c0f26f..84e2ae42f 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -14,5 +14,8 @@ endif
# FIXME -- this is temporary
OPTIMIZE_FOR_CPU=$(ARCH)
+# late binding check to see if the target cc supports -fwhole-program
+CFLAGS_WHOLE_PROGRAM = $(call cc-option,-fwhole-program,)
+
# gcc has a bunch of needed stuff....
include toolchain/gcc/Makefile.in