summaryrefslogtreecommitdiff
path: root/toolchain/ccache
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/ccache')
-rw-r--r--toolchain/ccache/Config.in8
-rw-r--r--toolchain/ccache/Config.in.28
-rw-r--r--toolchain/ccache/Makefile.in5
3 files changed, 13 insertions, 8 deletions
diff --git a/toolchain/ccache/Config.in b/toolchain/ccache/Config.in
index 1d27987c4..a265375c4 100644
--- a/toolchain/ccache/Config.in
+++ b/toolchain/ccache/Config.in
@@ -2,15 +2,9 @@
comment "Ccache Options"
-config BR2_HOST_CCACHE
+config BR2_CCACHE
bool "Enable ccache support?"
default y
help
Enable ccache support?
-config BR2_PACKAGE_CCACHE
- bool "Enable ccache support for the Target?"
- default y
- help
- Enable ccache support?
-
diff --git a/toolchain/ccache/Config.in.2 b/toolchain/ccache/Config.in.2
new file mode 100644
index 000000000..713037461
--- /dev/null
+++ b/toolchain/ccache/Config.in.2
@@ -0,0 +1,8 @@
+#
+
+config BR2_PACKAGE_CCACHE_TARGET
+ bool"ccache support in the target filesystem"
+ default n
+ help
+ Add help text here.
+
diff --git a/toolchain/ccache/Makefile.in b/toolchain/ccache/Makefile.in
index 6fa95d422..cc3c15e84 100644
--- a/toolchain/ccache/Makefile.in
+++ b/toolchain/ccache/Makefile.in
@@ -1,3 +1,6 @@
-ifeq ($(strip $(BR2_HOST_CCACHE)),y)
+ifeq ($(strip $(BR2_CCACHE)),y)
+TARGETS+=ccache
+endif
+ifeq ($(strip $(BR2_PACKAGE_CCACHE_TARGET)),y)
TARGETS+=ccache
endif