summaryrefslogtreecommitdiff
path: root/toolchain/elf2flt/elf2flt/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/elf2flt/elf2flt/configure.in')
-rw-r--r--toolchain/elf2flt/elf2flt/configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/toolchain/elf2flt/elf2flt/configure.in b/toolchain/elf2flt/elf2flt/configure.in
index b0335d77c..ae5dd270a 100644
--- a/toolchain/elf2flt/elf2flt/configure.in
+++ b/toolchain/elf2flt/elf2flt/configure.in
@@ -25,6 +25,12 @@ AC_ARG_WITH(binutils-include-dir,
[ ac_binutils_include_dir=NONE ]
)
+AC_ARG_WITH(binutils-ldscript-dir,
+ [ --with-binutils-ldscript-dir=<dir> path to install elf2flt.ld ],
+ [ ac_binutils_ldscript_dir=$withval ],
+ [ ac_binutils_ldscript_dir=NONE ]
+)
+
AC_ARG_ENABLE(got-check,
[ --disable-got-check - disable check for GOT (needed on H8) ],
[ got_check=$enableval ],
@@ -62,6 +68,12 @@ if test "$ac_binutils_include_dir" != "NONE"; then
binutils_include_dir="-I$ac_binutils_include_dir"
fi
+binutils_ldscript_dir=
+if test "$ac_binutils_ldscript_dir" = "NONE"; then
+ ac_binutils_ldscript_dir="\${TOOLDIR}/../${target_alias}/lib"
+fi
+binutils_ldscript_dir="$ac_binutils_ldscript_dir"
+
if test "$ac_libbfd" = "NONE" -o "$ac_libiberty" = "NONE" ; then
echo
echo "You need to specify the location of the libfd.a and libiberty.a"
@@ -108,6 +120,7 @@ AC_SUBST(target_os)
AC_SUBST(target_vendor)
AC_SUBST(bfd_include_dir)
AC_SUBST(binutils_include_dir)
+AC_SUBST(binutils_ldscript_dir)
AC_SUBST(got_check)
AC_OUTPUT(Makefile ld-elf2flt)