summaryrefslogtreecommitdiff
path: root/toolchain/elf2flt/elf2flt/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/elf2flt/elf2flt/configure.in')
-rw-r--r--toolchain/elf2flt/elf2flt/configure.in47
1 files changed, 27 insertions, 20 deletions
diff --git a/toolchain/elf2flt/elf2flt/configure.in b/toolchain/elf2flt/elf2flt/configure.in
index ae5dd270a..73443c6a3 100644
--- a/toolchain/elf2flt/elf2flt/configure.in
+++ b/toolchain/elf2flt/elf2flt/configure.in
@@ -37,6 +37,12 @@ AC_ARG_ENABLE(got-check,
[ got_check=yes ]
)
+AC_ARG_ENABLE(emit_relocs,
+ [ --disable-emit-relocs - don't use the --emit-relocs (-q) linker option ],
+ [ emit_relocs=$enableval ],
+ [ emit_relocs=yes ]
+)
+
AC_CANONICAL_HOST
AC_CANONICAL_TARGET
@@ -75,29 +81,29 @@ fi
binutils_ldscript_dir="$ac_binutils_ldscript_dir"
if test "$ac_libbfd" = "NONE" -o "$ac_libiberty" = "NONE" ; then
- echo
- echo "You need to specify the location of the libfd.a and libiberty.a"
- echo "host libraries from the binutils package."
- echo
- echo "Run configure again specifying these options:"
- echo
- echo " ./configure --target=<ARCH> --with-bfd-include-dir=<dir> --with-libbfd=<libbfd.a> --with-libiberty=<libiberty.a>"
- echo
- exit 1
+ AC_MSG_ERROR([
+
+You need to specify the location of the libfd.a and libiberty.a
+host libraries from the binutils package.
+
+Run configure again specifying these options:
+
+ ./configure --target=<ARCH> --with-bfd-include-dir=<dir> --with-libbfd=<libbfd.a> --with-libiberty=<libiberty.a>
+])
fi
if test "$ac_bfd_include_dir" = "NONE" ; then
- echo
- echo "You need to specify the location of the bfd.h header from a"
- echo "configured/compiled version of the binutils package for your target."
- echo "Without this your elf2flt may crash as it will try to use the"
- echo "systems bfd.h which may be from a different binutils package."
- echo
- echo "Run configure again specifying these options:"
- echo
- echo " ./configure --target=<ARCH> --with-bfd-include-dir=<dir> --with-libbfd=<libbfd.a> --with-libiberty=<libiberty.a>"
- echo
- exit 1
+ AC_MSG_ERROR([
+
+You need to specify the location of the bfd.h header from a
+configured/compiled version of the binutils package for your target.
+Without this your elf2flt may crash as it will try to use the
+systems bfd.h which may be from a different binutils package.
+
+Run configure again specifying these options:
+
+ ./configure --target=<ARCH> --with-bfd-include-dir=<dir> --with-libbfd=<libbfd.a> --with-libiberty=<libiberty.a>
+])
fi
dnl Checks for header files.
@@ -122,6 +128,7 @@ AC_SUBST(bfd_include_dir)
AC_SUBST(binutils_include_dir)
AC_SUBST(binutils_ldscript_dir)
AC_SUBST(got_check)
+AC_SUBST(emit_relocs)
AC_OUTPUT(Makefile ld-elf2flt)