summaryrefslogtreecommitdiff
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index c57b5ab86..dd3ad0978 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -249,7 +249,15 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
fi
# Strip the host binaries
ifeq ($(GCC_STRIP_HOST_BINARIES),true)
- -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/*
+ if [ -e $(STAGING_DIR)/usr/bin/*-gccbug ] ; then \
+ mkdir -p "$(STAGING_DIR)/tmp" ; \
+ mv $(STAGING_DIR)/usr/bin/*-gccbug $(STAGING_DIR)/tmp ; \
+ -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/* ; \
+ mv $(STAGING_DIR)/tmp/*-gccbug $(STAGING_DIR)/usr/bin ; \
+ rmdir "$(STAGING_DIR)/tmp" ; \
+ else \
+ -strip --strip-all -R .note -R .comment $(STAGING_DIR)/usr/bin/* ; \
+ fi
endif
# Make sure we have 'cc'.
if [ ! -e $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc ] ; then \