summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/4.4.1/100-uclibc-conf.patch (renamed from toolchain/gcc/4.4.0/100-uclibc-conf.patch)0
-rw-r--r--toolchain/gcc/4.4.1/301-missing-execinfo_h.patch (renamed from toolchain/gcc/4.4.0/301-missing-execinfo_h.patch)0
-rw-r--r--toolchain/gcc/4.4.1/302-c99-snprintf.patch (renamed from toolchain/gcc/4.4.0/302-c99-snprintf.patch)0
-rw-r--r--toolchain/gcc/4.4.1/305-libmudflap-susv3-legacy.patch (renamed from toolchain/gcc/4.4.0/305-libmudflap-susv3-legacy.patch)0
-rw-r--r--toolchain/gcc/4.4.1/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/4.4.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/Config.in2
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk7
7 files changed, 7 insertions, 2 deletions
diff --git a/toolchain/gcc/4.4.0/100-uclibc-conf.patch b/toolchain/gcc/4.4.1/100-uclibc-conf.patch
index cca8c8229..cca8c8229 100644
--- a/toolchain/gcc/4.4.0/100-uclibc-conf.patch
+++ b/toolchain/gcc/4.4.1/100-uclibc-conf.patch
diff --git a/toolchain/gcc/4.4.0/301-missing-execinfo_h.patch b/toolchain/gcc/4.4.1/301-missing-execinfo_h.patch
index 0e2092f3f..0e2092f3f 100644
--- a/toolchain/gcc/4.4.0/301-missing-execinfo_h.patch
+++ b/toolchain/gcc/4.4.1/301-missing-execinfo_h.patch
diff --git a/toolchain/gcc/4.4.0/302-c99-snprintf.patch b/toolchain/gcc/4.4.1/302-c99-snprintf.patch
index ba51a0e1d..ba51a0e1d 100644
--- a/toolchain/gcc/4.4.0/302-c99-snprintf.patch
+++ b/toolchain/gcc/4.4.1/302-c99-snprintf.patch
diff --git a/toolchain/gcc/4.4.0/305-libmudflap-susv3-legacy.patch b/toolchain/gcc/4.4.1/305-libmudflap-susv3-legacy.patch
index 374b1f865..374b1f865 100644
--- a/toolchain/gcc/4.4.0/305-libmudflap-susv3-legacy.patch
+++ b/toolchain/gcc/4.4.1/305-libmudflap-susv3-legacy.patch
diff --git a/toolchain/gcc/4.4.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/4.4.1/810-arm-softfloat-libgcc.patch
index e6a30a3f0..e6a30a3f0 100644
--- a/toolchain/gcc/4.4.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/4.4.1/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 9aba2f7d3..76e7f78db 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -105,7 +105,7 @@ config BR2_GCC_VERSION
default "4.3.1" if BR2_GCC_VERSION_4_3_1
default "4.3.2" if BR2_GCC_VERSION_4_3_2
default "4.3.3" if BR2_GCC_VERSION_4_3_3
- default "4.4.0" if BR2_GCC_VERSION_4_4_X
+ default "4.4.1" if BR2_GCC_VERSION_4_4_X
default "4.3" if BR2_GCC_VERSION_4_3
config BR2_TOOLCHAIN_SYSROOT
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 5770081b3..e9249c1c5 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -50,6 +50,11 @@ endif # Snapshot patch
endif # Not a snapshot
endif # BR2_TOOLCHAIN_BUILDROOT
+ifneq ($(filter xtensa%,$(ARCH)),)
+include target/xtensa/patch.in
+GCC_PATCH_EXTRA:=$(call XTENSA_PATCH,gcc,$(GCC_PATCH_DIR),. ..)
+endif
+
GCC_SOURCE:=gcc-$(GCC_OFFICIAL_VERSION).tar.bz2
GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-$(GCC_OFFICIAL_VERSION)
GCC_CAT:=$(BZCAT)
@@ -164,7 +169,7 @@ $(GCC_DIR)/.unpacked: $(DL_DIR)/$(GCC_SOURCE)
gcc-patched: $(GCC_DIR)/.patched
$(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
# Apply any files named gcc-*.patch from the source directory to gcc
- toolchain/patch-kernel.sh $(GCC_DIR) $(GCC_PATCH_DIR) \*.patch
+ toolchain/patch-kernel.sh $(GCC_DIR) $(GCC_PATCH_DIR) \*.patch $(GCC_PATCH_EXTRA)
# Note: The soft float situation has improved considerably with gcc 3.4.x.
# We can dispense with the custom spec files, as well as libfloat for the arm case.