summaryrefslogtreecommitdiff
path: root/toolchain/toolchain-crosstool-ng
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/toolchain-crosstool-ng')
-rw-r--r--toolchain/toolchain-crosstool-ng/001-no-cvs.patch15
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.mk10
2 files changed, 24 insertions, 1 deletions
diff --git a/toolchain/toolchain-crosstool-ng/001-no-cvs.patch b/toolchain/toolchain-crosstool-ng/001-no-cvs.patch
new file mode 100644
index 000000000..fd805d331
--- /dev/null
+++ b/toolchain/toolchain-crosstool-ng/001-no-cvs.patch
@@ -0,0 +1,15 @@
+Remove dependency on cvs.
+
+cvs is used to retrieve newlib, which is not supported
+under Buildroot, so cvs is not required.
+
+--- crosstool-ng-1.8.0/configure.orig 2010-11-27 15:43:52.000000000 +0000
++++ crosstool-ng-1.8.0/configure 2010-11-27 15:44:10.000000000 +0000
+@@ -359,7 +359,6 @@
+ err="'libtool' 1.5.26 or above was not found"
+ has_or_abort prog=stat
+ has_or_abort prog="aria2c curl wget"
+-has_or_abort prog=cvs
+ has_or_abort prog=patch
+ has_or_abort prog=tar
+ has_or_abort prog=gzip
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index 0812216a3..9a9f2720e 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -267,8 +267,16 @@ $(CTNG_DIR)/.patched: $(CTNG_DIR)/.unpacked
\*.patch.$(ARCH)
$(Q)touch $@
+# Use order-only dependencies on host-* as they
+# are virtual targets with no rules, and so are
+# considered always remade. But we do not want
+# to reconfigure and rebuild ct-ng every time
+# we need to run it...
+$(CTNG_DIR)/.configured: | host-gawk \
+ host-automake
+
$(CTNG_DIR)/.configured: $(CTNG_DIR)/.patched
- $(Q)cd $(CTNG_DIR) && ./configure --local
+ $(Q)cd $(CTNG_DIR) && PATH=$(HOST_PATH) ./configure --local
$(Q)touch $@
$(CTNG_DIR)/ct-ng: $(CTNG_DIR)/.configured