From 0a62bb41ba949cd5615069285de318150751d800 Mon Sep 17 00:00:00 2001 From: grante Date: Thu, 10 Dec 2009 16:12:21 -0600 Subject: docs: Clean up punctuation, grammar, usage, and typos. Closes #795. Signed-off-by: Grant Edwards Signed-off-by: Peter Korsgaard --- docs/buildroot.html | 463 ++++++++++++++++++++++++++-------------------------- 1 file changed, 233 insertions(+), 230 deletions(-) (limited to 'docs/buildroot.html') diff --git a/docs/buildroot.html b/docs/buildroot.html index c4f191a35..0d254b619 100644 --- a/docs/buildroot.html +++ b/docs/buildroot.html @@ -46,17 +46,17 @@

About Buildroot

-

Buildroot is a set of Makefiles and patches that allow to +

Buildroot is a set of Makefiles and patches that allows you to easily generate a cross-compilation toolchain, a root filesystem and a Linux kernel image for your target. Buildroot can be used - for either one, two or all of these options, independently.

+ for one, two or all of these options, independently.

Buildroot is useful mainly for people working with embedded systems. Embedded systems often use processors that are not the regular x86 - processors everyone is used to have on his PC. It can be PowerPC + processors everyone is used to having in his PC. They can be PowerPC processors, MIPS processors, ARM processors, etc.

-

A compilation toolchain is the set of tools that allows to +

A compilation toolchain is the set of tools that allows you to compile code for your system. It consists of a compiler (in our case, gcc), binary utils like assembler and linker (in our case, binutils) and a C standard library (for @@ -64,55 +64,57 @@ Libc, uClibc or dietlibc). The system installed on your development station certainly already has a - compilation toolchain that you can use to compile application that + compilation toolchain that you can use to compile an application that runs on your system. If you're using a PC, your compilation - toolchain runs on an x86 processor and generates code for a x86 + toolchain runs on an x86 processor and generates code for an x86 processor. Under most Linux systems, the compilation toolchain - uses the GNU libc as C standard library. This compilation - toolchain is called the "host compilation toolchain", and more - generally, the machine on which it is running, and on which you're - working is called the "host system". The compilation toolchain + uses the GNU libc (glibc) as the C standard library. This compilation + toolchain is called the "host compilation toolchain". + The machine on which it is running, and on which you're + working, is called the "host system". The compilation toolchain is provided by your distribution, and Buildroot has nothing to do - with it.

+ with it (other than using it to build a cross-compilation toolchain + and other tools that are run on the development host).

As said above, the compilation toolchain that comes with your system - runs and generates code for the processor of your host system. As your + runs on and generates code for the processor in your host system. As your embedded system has a different processor, you need a cross-compilation - toolchain: it's a compilation toolchain that runs on your host system but - that generates code for your target system (and target processor). For + toolchain — a compilation toolchain that runs on your host system but + generates code for your target system (and target processor). For example, if your host system uses x86 and your target system uses ARM, the - regular compilation toolchain of your host runs on x86 and generates code + regular compilation toolchain on your host runs on x86 and generates code for x86, while the cross-compilation toolchain runs on x86 and generates code for ARM.

-

Even if your embedded system uses a x86 processor, you might interested - in Buildroot, for two reasons:

+

Even if your embedded system uses an x86 processor, you might be interested + in Buildroot for two reasons:

    -
  • The compilation toolchain of your host certainly uses the GNU Libc +
  • The compilation toolchain on your host certainly uses the GNU Libc which is a complete but huge C standard library. Instead of using GNU Libc on your target system, you can use uClibc which is a tiny C standard library. If you want to use this C library, then you need a compilation - toolchain to generate binaries linked with it. Buildroot can do it for + toolchain to generate binaries linked with it. Buildroot can do that for you.
  • Buildroot automates the building of a root filesystem with all needed - tools like busybox. It makes it much easier than doing it by hand.
  • + tools like busybox. That makes it much easier than doing it by hand.

You might wonder why such a tool is needed when you can compile - gcc, binutils, uClibc and all the tools by hand. - Of course, doing so is possible. But dealing with all configure options, - with all problems of every gcc or binutils - version it very time-consuming and uninteresting. Buildroot automates this - process through the use of Makefiles, and has a collection of patches for + gcc, binutils, uClibc and all + the other tools by hand. + Of course doing so is possible. But, dealing with all of the configure options + and problems of every gcc or binutils + version is very time-consuming and uninteresting. Buildroot automates this + process through the use of Makefiles and has a collection of patches for each gcc and binutils version to make them work on most architectures.

Moreover, Buildroot provides an infrastructure for reproducing - the build process of your embedded root filesystem. Being able to + the build process of your kernel, cross-toolchain, and embedded root filesystem. Being able to reproduce the build process will be useful when a component needs - to be patched or updated, or when another person is supposed to + to be patched or updated or when another person is supposed to take over the project.

Obtaining Buildroot

@@ -129,12 +131,12 @@ and previous snapshots are also available at http://buildroot.net/downloads/snapshots/.

-

To download Buildroot using Git, you can simply follow - the rules described on the "Accessing Git"-page (To download Buildroot using Git you can simply follow + the rules described on the "Accessing Git" page (http://buildroot.net/git.html) of the Buildroot website (http://buildroot.net), and download - buildroot from Git. For the impatient, here's a quick + "http://buildroot.net">http://buildroot.net). + For the impatient, here's a quick recipe:

@@ -144,10 +146,10 @@
     

Using Buildroot

Buildroot has a nice configuration tool similar to the one you can find - in the Linux Kernel (http://www.kernel.org/) or in Busybox (http://www.busybox.org/). Note that - you can build everything as a normal user. There is no need to be root to + you can (and should) build everything as a normal user. There is no need to be root to configure and use Buildroot. The first step is to run the configuration assistant:

@@ -161,15 +163,20 @@ $ make xconfig
-

to run the Qt3-based configurator. On Debian-like systems, the +

to run the Qt3-based configurator.

+ +

Both of these "make" commands will need to build a configuration + utility, so you may need to install "development" packages for + relevent libraries used by the configuration utilities. + On Debian-like systems, the libncurses5-dev package is required to use the menuconfig interface, and the libqt3-mt-dev is required to use the xconfig interface.

-

For each entry of the configuration tool, you can find associated help +

For each menu entry in the configuration tool, you can find associated help that describes the purpose of the entry.

-

Once everything is configured, the configuration tool has generated a +

Once everything is configured, the configuration tool generates a .config file that contains the description of your configuration. It will be used by the Makefiles to do what's needed.

@@ -179,11 +186,18 @@
  $ make
 
- -

This command will download, configure and compile all the - selected tools, and finally generate a toolchain, a root - filesystem image and a kernel image (or only one of these - elements, depending on the configuration).

+

This command will generally perform the following steps:

+
    +
  • Download source files (as required)
  • +
  • Configure cross-compile toolchain
  • +
  • Build/install cross-compile toolchain
  • +
  • Build/install selected target packages
  • +
  • Build a kernel image
  • +
  • Create a root filesystem in selected formats
  • +
+

Some of the above steps might not be performed if they are not + selected in the Buildroot configuration. +

Buildroot output is stored in a single directory, output/. This directory contains several @@ -194,19 +208,19 @@

  • images/ where all the images (kernel image, bootloader and root filesystem images) are stored.
  • -
  • build/ where all the components are built - (tools needed to run Buildroot on the host and packages compiled +
  • build/ where all the components except for the + cross-compilation toolchain are built + (this includes tools needed to run Buildroot on the host and packages compiled for the target). The build/ directory contains one - subdirectory for each of these components. The toolchain - components are however built in a separate directory.
  • + subdirectory for each of these components.
  • staging/ which contains a hierarchy similar to a root filesystem hierarchy. This directory contains the - installation of cross-compilation toolchain and all the + installation of the cross-compilation toolchain and all the userspace packages selected for the target. However, this directory is not intended to be the root filesystem for the target: it contains a lot of development files, unstripped - binaries and libraries, that make it far too big for an embedded + binaries and libraries that make it far too big for an embedded system.
  • target/ which contains almost the root @@ -214,18 +228,19 @@ the device files in /dev/ (Buildroot can't create them because Buildroot doesn't run as root and does not want to run as root). Therefore, this directory should not be used on - your target but instead you should use one of the images + your target. Instead, you should use one of the images built in the images/ directory. If you need an - extracted image of the root filesystem, for booting over NFS, + extracted image of the root filesystem for booting over NFS, then use the tarball image generated in images/ and extract it as root.
    Compared to staging/, - target/ contains only the necessary files to run - the libraries and applications: all the development files + target/ contains only the files and libraries needed + to run the selected target applications: the development files (headers, etc.) are not present.
  • host/ contains the installation of tools compiled for the host that are needed for the proper execution - of Buildroot.
  • + of Buildroot except for the cross-compilation toolchain which is + installed under staging/.
  • toolchain/ contains the build directories for the various components of the cross-compilation toolchain.
  • @@ -235,9 +250,9 @@

    Offline builds

    -

    If you intend to do an offline-build and just want to download +

    If you intend to do an offline build and just want to download all sources that you previously selected in the configurator - (menuconfig or xconfig) then issue:

    + (menuconfig or xconfig), then issue:

      $ make source
     
    @@ -249,31 +264,31 @@

    Buildroot supports building out of tree with a syntax similar to the Linux kernel. To use it, add O=<directory> to the - make command line, E.G.:

    + make command line:

      $ make O=/tmp/build
     
    -

    And all the output files will be located under +

    All the output files will be located under /tmp/build.

    Environment variables

    -

    Buildroot optionally honors some environment variables that are passed - to make :

    +

    Buildroot also honors some environment variables when they are passed + to make:

    • HOSTCXX, the host C++ compiler to use
    • HOSTCC, the host C compiler to use
    • UCLIBC_CONFIG_FILE=<path/to/.config>, path to the uClibc configuration file to use to compile uClibc if an - internal toolchain is selected
    • + internal toolchain is being built
    • BUSYBOX_CONFIG_FILE=<path/to/.config>, path to the Busybox configuration file
    • LINUX26_KCONFIG=<path/to/.config>, path to the Linux kernel configuration file
    • -
    • BUILDROOT_COPYTO, an additional location at which +
    • BUILDROOT_COPYTO, an additional location to which the binary images of the root filesystem, kernel, etc. built by Buildroot are copied
    • BUILDROOT_DL_DIR to override the directory in @@ -307,48 +322,48 @@ $ export BUILDROOT_COPYTO=/tftpboot

      There are a few ways to customize the resulting target filesystem:

        -
      • Customize the target filesystem directly, and rebuild the image. The +
      • Customize the target filesystem directly and rebuild the image. The target filesystem is available under output/target/. - You can simply make your changes here, and run make afterwards, which will - rebuild the target filesystem image. This method allows to do everything - on the target filesystem, but if you decide to completely rebuild your + You can simply make your changes here and run make afterwards — this will + rebuild the target filesystem image. This method allows you to do anything + to the target filesystem, but if you decide to completely rebuild your toolchain and tools, these changes will be lost.
      • -
      • Customize the target filesystem skeleton, available under +
      • Customize the target filesystem skeleton available under target/generic/target_skeleton/. You can customize configuration files or other stuff here. However, the full file hierarchy - is not yet present, because it's created during the compilation process. - So you can't do everything on this target filesystem skeleton, but - changes to it remain even if you completely rebuild the cross-compilation + is not yet present because it's created during the compilation process. + Therefore, you can't do everything on this target filesystem skeleton, but + changes to it do remain even if you completely rebuild the cross-compilation toolchain and the tools.
        You can also customize the target/generic/device_table.txt file which is used by the tools that generate the target filesystem image to properly set permissions and create device nodes.
        These customizations are deployed into output/target/ just before the actual image - is made. So simply rebuilding the image by running + is made. Simply rebuilding the image by running make should propagate any new changes to the image.
      • Add support for your own target in Buildroot so that you - have your own target skeleton, see this - section for details
      • + have your own target skeleton (see this + section for details). -
      • In Buildroot configuration, you can specify the path to a - post-build script that gets called after Buildroot built - all the selected software, but before the the rootfs +
      • In the Buildroot configuration, you can specify the path to a + post-build script that gets called after Buildroot builds + all the selected software but before the the rootfs packages are assembled. The destination root filesystem folder - is given as first argument to this script, and this script can + is given as the first argument to this script, and this script can then be used to copy programs, static data or any other needed file to your target filesystem.
        You should, however, use - that feature with care. Whenever you find that a certain package - generates wrong or unneeded files, you should rather fix than - package than working around it with a cleanup script.
      • + this feature with care. Whenever you find that a certain package + generates wrong or unneeded files, you should fix that + package rather than work around it with a post-build cleanup script.
      • A special package, customize, stored in package/customize can be used. You can put all the files that you want to see in the final target root filesystem - in package/customize/source, and then enable this - special package from the configuration system.
      • + in package/customize/source and then enable this + special package in the configuration system.
      @@ -357,18 +372,18 @@ $ export BUILDROOT_COPYTO=/tftpboot

      Busybox is very configurable, and you may want to customize it. You can - follow these simple steps to do it. It's not an optimal way, but it's - simple and it works.

      + follow these simple steps to do so. This method isn't optimal, but it's + simple and it works:

        -
      1. Make a first compilation of buildroot with busybox without trying to +
      2. Do an initial compilation of Buildroot with busybox without trying to customize it.
      3. Invoke make busybox-menuconfig. - The nice configuration tool appears and you can + The nice configuration tool appears, and you can customize everything.
      4. -
      5. Run the compilation of buildroot again.
      6. +
      7. Run the compilation of Buildroot again.

      Otherwise, you can simply change the @@ -383,21 +398,21 @@ $ export BUILDROOT_COPYTO=/tftpboot

      Just like BusyBox, uClibc offers a lot of - configuration options. They allow to select various - functionalities, depending on your needs and limitations.

      + configuration options. They allow you to select various + functionalities depending on your needs and limitations.

      The easiest way to modify the configuration of uClibc is to - follow these steps :

      + follow these steps:

        -
      1. Make a first compilation of buildroot without trying to +
      2. Do an initial compilation of Buildroot without trying to customize uClibc.
      3. Invoke make uclibc-menuconfig. The nice configuration assistant, similar to - the one used in the Linux Kernel or in Buildroot appears. Make - your configuration as appropriate.
      4. + the one used in the Linux kernel or Buildroot, appears. Make + your configuration changes as appropriate.
      5. Copy the .config file to toolchain/uClibc/uClibc.config or @@ -406,7 +421,7 @@ $ export BUILDROOT_COPYTO=/tftpboot configuration, and the latter is used if you have selected locale support.
      6. -
      7. Run the compilation of Buildroot again
      8. +
      9. Run the compilation of Buildroot again.
      @@ -434,18 +449,18 @@ $ export BUILDROOT_COPYTO=/tftpboot id="rebuilding_packages">Understanding how to rebuild packages -

      One of the most common question and issue about Buildroot - encountered by users is how to rebuild a given package or how to +

      One of the most common questions asked by Buildroot + users is how to rebuild a given package or how to remove a package without rebuilding everything from scratch.

      Removing a package is currently unsupported by Buildroot without rebuilding from scratch. This is because Buildroot doesn't keep track of which package installs what files in the output/staging and output/target - directories. However, implement clean package removal is on the + directories. However, implementing clean package removal is on the TODO-list of Buildroot developers.

      -

      To rebuild a single package from scratch, the easiest way is to +

      The easiest way to rebuild a single package from scratch is to remove its build directory in output/build. Buildroot will then re-extract, re-configure, re-compile and re-install this package from scratch.

      @@ -453,26 +468,26 @@ $ export BUILDROOT_COPYTO=/tftpboot

      However, if you don't want to rebuild the package completely from scratch, a better understanding of the Buildroot internals is needed. Internally, to keep track of which steps have been done - and which steps remains to be done, Buildroot maintains stamps - files (i.e, empty files that just tell whether this or this action - has been done). The problem is that these stamps files are not + and which steps remain to be done, Buildroot maintains stamp + files (empty files that just tell whether this or that action + has been done). The problem is that these stamp files are not uniformely named and handled by the different packages, so some understanding of the particular package is needed.

      For packages relying on the autotools Buildroot infrastructure (see this section for - details), the following stamps files are interesting:

      + details), the following stamp files are relevent:

      • output/build/packagename-version/.stamp_configured. If removed, Buildroot will trigger the recompilation of the package from the configuration step (execution of - ./configure)
      • + ./configure).
      • output/build/packagename-version/.stamp_built. If removed, Buildroot will trigger the recompilation of the package - from the compilation step (execution of make)
      • + from the compilation step (execution of make).
      @@ -492,32 +507,28 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured touch -c $@ -

      So, if you want to trigger the reconfiguration, you need to - remove output/build/zlib-version/.configured and if +

      If you want to trigger the reconfiguration, you need to + remove output/build/zlib-version/.configured. If you want to trigger only the recompilation, you need to remove output/build/zlib-version/libz.a.

      How Buildroot works

      -

      As said above, Buildroot is basically a set of Makefiles that download, - configure and compiles software with the correct options. It also includes - some patches for various software, mainly the ones involved in the +

      As mentioned above, Buildroot is basically a set of Makefiles that downloads, + configures and compiles software with the correct options. It also includes + patches for various software packages — mainly the ones involved in the cross-compilation tool chain (gcc, binutils and - uClibc).

      + uClibc).

      -

      There is basically one Makefile per software, and they are named with +

      There is basically one Makefile per software package, and they are named with the .mk extension. Makefiles are split into four sections:

        -
      • project (in the project/ directory) contains - the Makefiles and associated files for all software related to the - building several root file systems in the same buildroot tree.
      • -
      • toolchain (in the toolchain/ directory) contains the Makefiles and associated files for all software related to the - cross-compilation toolchain : binutils, ccache, + cross-compilation toolchain: binutils, ccache, gcc, gdb, kernel-headers and uClibc.
      • @@ -528,27 +539,27 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured
      • target (in the target directory) contains the Makefiles and associated files for software related to the generation of - the target root filesystem image. Four types of filesystems are supported - : ext2, jffs2, cramfs and squashfs. For each of them, there's a + the target root filesystem image. Four types of filesystems are supported: + ext2, jffs2, cramfs and squashfs. For each of them there is a sub-directory with the required files. There is also a default/ directory that contains the target filesystem skeleton.
      -

      Each directory contains at least 2 files :

      +

      Each directory contains at least 2 files:

      • something.mk is the Makefile that downloads, configures, - compiles and installs the software something.
      • + compiles and installs the package something.
      • Config.in is a part of the configuration tool - description file. It describes the option related to the current - software.
      • + description file. It describes the options related to the + package.
      -

      The main Makefile do the job through the following steps (once the - configuration is done) :

      +

      The main Makefile performs the following steps (once the + configuration is done):

        @@ -559,14 +570,14 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured
      1. Generate all the targets listed in the BASE_TARGETS variable. When an internal toolchain - is used, it means generating the cross-compilation - toolchain. When an external toolchain is used, it means checking + is used, this means generating the cross-compilation + toolchain. When an external toolchain is used, this means checking the features of the external toolchain and importing it into the Buildroot environment.
      2. Generate all the targets listed in the TARGETS variable. This variable is filled by all the individual - components Makefiles. So, generating all these targets will + components' Makefiles. Generating these targets will trigger the compilation of the userspace packages (libraries, programs), the kernel, the bootloader and the generation of the root filesystem images, depending on the configuration.
      3. @@ -577,15 +588,14 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured Creating your own board support

        Creating your own board support in Buildroot allows you to have - a convenient place to store the Busybox, uClibc, kernel - configurations, your target filesystem skeleton, and a Buildroot - configuration that match your project.

        + a convenient place to store your project's target filesystem skeleton + and configuration files for Buildroot, Busybox, uClibc, and the kernel.

        Follow these steps to integrate your board in Buildroot:

          -
        1. Create a new directory in target/device/, named +
        2. Create a new directory in target/device/ named after your company or organization
        3. Add a line source @@ -595,8 +605,7 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured
        4. In target/device/yourcompany/, create a directory for your project. This way, you'll be able to store - several projects of your company/organization inside - Buildroot.
        5. + several of your company's projects inside Buildroot.
        6. Create a target/device/yourcompany/Config.in file that looks like the following: @@ -615,7 +624,7 @@ config BR2_TARGET_COMPANY_PROJECT_FOOBAR endif - Of course, customize the different values to match your + Of course, you should customize the different values to match your company/organization and your project. This file will create a menu entry that contains the different projects of your company/organization.
        7. @@ -630,11 +639,11 @@ endif -
        8. Now, create the +
        9. Create the target/device/yourcompany/project-foobar/Makefile.in - file. It is first recommended to define a + file. It is recommended that you define a BOARD_PATH variable set to - target/device/yourcompany/project-foobar, as it + target/device/yourcompany/project-foobar as it will simplify further definitions. Then, the file might define one or several of the following variables: @@ -644,12 +653,12 @@ endif the target skeleton for your project. If this variable is defined, this target skeleton will be used instead of the default one. If defined, the convention is to define it to - $(BOARD_PATH)/target_skeleton, so that the target - skeletonn is stored in the board specific directory.
        10. + $(BOARD_PATH)/target_skeleton so that the target + skeleton is stored in the board specific directory.
        11. TARGET_DEVICE_TABLE to a file that contains - the target device table, i.e the list of device files (in - /dev/) created by the root filesystem building + the target device table — the list of device files (in + /dev/) to be created by the root filesystem build procedure. If this variable is defined, the given device table will be used instead of the default one. If defined, the convention is to define it to @@ -661,14 +670,14 @@ endif
        12. -
        13. Then, in the +
        14. In the target/device/yourcompany/project-foobar/ - directory, you can store configuration files for the kernel, - for Busybox or uClibc. + directory you can store configuration files for the kernel, + Busybox or uClibc. You can furthermore create one or more preconfigured configuration files, referencing those files. These config files are named - something_defconfig and are stored in the toplevel + something_defconfig and are stored in the toplevel configs/ directory. Your users will then be able to run make something_defconfig and get the right configuration for your project
        15. @@ -678,52 +687,45 @@ endif

          Using the generated toolchain outside Buildroot

          -

          You may want to compile your own programs or other software - that are not packaged in Buildroot. In order to do this, you can +

          You may want to compile for your target your own programs or other software + that are not packaged in Buildroot. In order to do this you can use the toolchain that was generated by Buildroot.

          -

          The toolchain generated by Buildroot by default is located in +

          The toolchain generated by Buildroot is located by default in output/staging/. The simplest way to use it is to add output/staging/usr/bin/ to your PATH - environnement variable, and then to use + environnement variable and then to use ARCH-linux-gcc, ARCH-linux-objdump, ARCH-linux-ld, etc.

          -

          The easiest way is of course to add the - output/staging/usr/bin/ directory to your PATH - environment variable.

          +

          Important: do not try to move a gcc-3.x toolchain to another + directory — it won't work because there are some hardcoded paths in the + gcc-3.x configuration. If you are using a current gcc-4.x, it + is possible to relocate the toolchain — but then + --sysroot must be passed every time the compiler is + called to tell where the libraries and header files are.

          -

          Important : do not try to move a gcc-3.x toolchain to an other - directory, it won't work. There are some hardcoded paths in the - gcc configuration. If you are using a current gcc-4.x, it - is possible to relocate the toolchain, but then - --sysroot must be passed every time the compiler is - called to tell where the libraries and header files are, which - might be cumbersome.

          - -

          It is also possible to generate the Buildroot toolchain in - another directory than output/staging using the - Build options -> Toolchain and header file - location option. This could be useful if the toolchain - must be shared with other users.

          +

          It is also possible to generate the Buildroot toolchain in + a directory other than output/staging by using the + Build options -> Toolchain and header file + location options. This could be useful if the toolchain + must be shared with other users.

          Location of downloaded packages

          It might be useful to know that the various tarballs that are - downloaded by the Makefiles are all stored in the + downloaded by the Makefiles are all stored in the DL_DIR which by default is the dl - directory. It's useful for example if you want to keep a complete + directory. It's useful, for example, if you want to keep a complete version of Buildroot which is know to be working with the associated tarballs. This will allow you to regenerate the toolchain and the target filesystem with exactly the same versions.

          -

          If you maintain several buildroot trees, it might be better to have +

          If you maintain several Buildroot trees, it might be better to have a shared download location. This can be accessed by creating a symbolic link - from the dl directory to the shared download location.

          - -

          I.E:

          + from the dl directory to the shared download location:

           ln -s <shared download location> dl
          @@ -759,7 +761,7 @@ toolchain.

        16. Adjust the External toolchain path appropriately. It should be set to a path where a bin/ directory contains your cross-compiling tools
        17. -
        18. Adjust the External toolchain prefix, so that the +
        19. Adjust the External toolchain prefix so that the prefix, suffixed with -gcc or -ld will correspond to your cross-compiling tools
    @@ -773,8 +775,8 @@ according to your cross-compiling toolchain.

    To generate external toolchains, we recommend using Crosstool-NG. -It allows to generate toolchains based on uClibc, glibc -and eglibc for a wide range of architectures, and has good +It allows generating toolchains based on uClibc, glibc +and eglibc for a wide range of architectures and has good community support.

    Extending Buildroot with @@ -791,9 +793,9 @@ community support.

    Config.in file

    Then, create a file named Config.in. This file - will contain the portion of options description related to our + will contain the option descriptions related to our foo software that will be used and displayed in the - configuration tool. It should basically contain :

    + configuration tool. It should basically contain:

     config BR2_PACKAGE_FOO
    @@ -817,24 +819,24 @@ source "package/procps/Config.in"
        Generally all packages should live directly in the
        package directory to make it easier to find them.
        

    -

    The real Makefile

    +

    The real Makefile

    Finally, here's the hardest part. Create a file named - foo.mk. It will contain the Makefile rules that + foo.mk. It will contain the Makefile rules that are in charge of downloading, configuring, compiling and installing the software.

    -

    Two types of Makefiles can be written :

    +

    Two types of Makefiles can be written :

    • Makefiles for autotools-based (autoconf, automake, etc.) - softwares, are very easy to write thanks to the infrastructure + software are very easy to write thanks to the infrastructure available in package/Makefile.autotools.in.
    • Makefiles for other types of packages are a little bit more complex to write.
    -

    First, let's see how to write a Makefile for an +

    First, let's see how to write a Makefile for an autotools-based package, with an example :

    @@ -854,9 +856,9 @@ source "package/procps/Config.in"
     

    On line 6, we declare the version of - the package. On line 7 and 7 and 8, we declare the name of the tarball and the - location of the tarball on the Web. Buildroot will automatically + location of the tarball on the web. Buildroot will automatically download the tarball from this location.

    On line 9, we tell Buildroot to install @@ -869,18 +871,18 @@ source "package/procps/Config.in"

    On line 10, we tell Buildroot to also install the application to the target directory. This directory contains what will become the root filesystem running on the - target. Usually, we try not to install the documentation, and to - install stripped versions of the binary. By default, packages are + target. Usually, we try to install stripped binaries and + to not install the documentation. By default, packages are installed in this location using the make install-strip command.

    On line 11, we tell Buildroot to pass - a custom configure option, that will be passed to the - ./configure script before configuring and building + a custom configure option to the + ./configure script when configuring the the package.

    On line 12, we declare our - dependencies, so that they are built before the build process of + dependencies so that they are built before the build process of our package starts.

    Finally, on line line 13, we invoke @@ -958,92 +960,93 @@ source "package/procps/Config.in"

    -

    First of all, this Makefile example works for a single - binary software. For other software such as libraries or more - complex stuff with multiple binaries, it should be adapted. Look at +

    First of all, this Makefile example works for a package which comprises a single + binary executable. For other software, such as libraries or more + complex stuff with multiple binaries, it must be adapted. For examples look at the other *.mk files in the package directory.

    At lines 6-11, a couple of useful variables are - defined :

    + defined:

      -
    • FOO_VERSION : The version of foo that +
    • FOO_VERSION: The version of foo that should be downloaded.
    • -
    • FOO_SOURCE : The name of the tarball of - foo on the download website of FTP site. As you can see +
    • FOO_SOURCE: The name of the tarball of + foo on the download website or FTP site. As you can see FOO_VERSION is used.
    • -
    • FOO_SITE : The HTTP or FTP site from which +
    • FOO_SITE: The HTTP or FTP site from which foo archive is downloaded. It must include the complete path to the directory where FOO_SOURCE can be found.
    • -
    • FOO_DIR : The directory into which the software +
    • FOO_DIR: The directory into which the software will be configured and compiled. Basically, it's a subdirectory of BUILD_DIR which is created upon decompression of the tarball.
    • -
    • FOO_BINARY : Software binary name. As said - previously, this is an example for a single binary software.
    • +
    • FOO_BINARY: Software binary name. As said + previously, this is an example for a package with a single binary.
    • -
    • FOO_TARGET_BINARY : The full path of the binary +
    • FOO_TARGET_BINARY: The full path of the binary inside the target filesystem.
    -

    Lines 13-14 defines a target that downloads the +

    Lines 13-14 define a target that downloads the tarball from the remote site to the download directory (DL_DIR).

    -

    Lines 16-18 defines a target and associated rules +

    Lines 16-18 define a target and associated rules that uncompress the downloaded tarball. As you can see, this target - depends on the tarball file, so that the previous target (line + depends on the tarball file so that the previous target (lines 13-14) is called before executing the rules of the current target. Uncompressing is followed by touching a hidden file - to mark the software has having been uncompressed. This trick is - used everywhere in Buildroot Makefile to split steps + to mark the software as having been uncompressed. This trick is + used everywhere in a Buildroot Makefile to split steps (download, uncompress, configure, compile, install) while still having correct dependencies.

    -

    Lines 20-31 defines a target and associated rules - that configures the software. It depends on the previous target (the +

    Lines 20-31 define a target and associated rules + that configure the software. It depends on the previous target (the hidden .source file) so that we are sure the software has - been uncompressed. In order to configure it, it basically runs the + been uncompressed. In order to configure the package, it basically runs the well-known ./configure script. As we may be doing cross-compilation, target, host and build arguments are given. The prefix is also set to /usr, not because the software will be installed in - /usr on your host system, but in the target + /usr on your host system, but because the software will + bin installed in /usr on the target filesystem. Finally it creates a .configured file to mark the software as configured.

    -

    Lines 33-34 defines a target and a rule that - compiles the software. This target will create the binary file in the - compilation directory, and depends on the software being already +

    Lines 33-34 define a target and a rule that + compile the software. This target will create the binary file in the + compilation directory and depends on the software being already configured (hence the reference to the .configured file). It basically runs make inside the source directory.

    -

    Lines 36-38 defines a target and associated rules - that install the software inside the target filesystem. It depends on the - binary file in the source directory, to make sure the software has - been compiled. It uses the install-strip target of the +

    Lines 36-38 define a target and associated rules + that install the software inside the target filesystem. They depend on the + binary file in the source directory to make sure the software has + been compiled. They use the install-strip target of the software Makefile by passing a DESTDIR - argument, so that the Makefile doesn't try to install - the software inside host /usr but inside target + argument so that the Makefile doesn't try to install + the software in the host /usr but rather in the target /usr. After the installation, the /usr/man directory inside the target filesystem is removed to save space.

    -

    Line 40 defines the main target of the software, +

    Line 40 defines the main target of the software — the one that will be eventually be used by the top level Makefile to download, compile, and then install - this package. This target should first of all depends on all - needed dependecies of the software (in our example, - uclibc and ncurses), and also depend on the + this package. This target should first of all depend on all + needed dependencies of the software (in our example, + uclibc and ncurses) and also depend on the final binary. This last dependency will call all previous dependencies in the correct order.

    @@ -1056,7 +1059,7 @@ source "package/procps/Config.in" if all package-sources are downloadable.

    Lines 44-46 define a simple target to clean the - software build by calling the Makefiles with the appropriate option. + software build by calling the Makefiles with the appropriate option. The -clean target should run make clean on $(BUILD_DIR)/package-version and MUST uninstall all files of the package from $(STAGING_DIR) and from $(TARGET_DIR).

    @@ -1066,11 +1069,11 @@ source "package/procps/Config.in" compiled. The -dirclean target MUST completely rm $(BUILD_DIR)/ package-version.

    -

    Lines 51-58 adds the target foo to +

    Lines 51-58 add the target foo to the list of targets to be compiled by Buildroot by first checking if the configuration option for this package has been enabled - using the configuration tool, and if so then "subscribes" - this package to be compiled by adding it to the TARGETS + using the configuration tool. If so, it then "subscribes" + this package to be compiled by adding the package to the TARGETS global variable. The name added to the TARGETS global variable is the name of this package's target, as defined on line 40, which is used by Buildroot to download, @@ -1079,13 +1082,13 @@ source "package/procps/Config.in"

    Conclusion

    -

    As you can see, adding a software to buildroot is simply a - matter of writing a Makefile using an already existing - example and to modify it according to the compilation process of - the software.

    +

    As you can see, adding a software package to Buildroot is simply a + matter of writing a Makefile using an existing + example and modifying it according to the compilation process required by + the package.

    -

    If you package software that might be useful for other persons, - don't forget to send a patch to Buildroot developers !

    +

    If you package software that might be useful for other people, + don't forget to send a patch to Buildroot developers!

    Resources

    -- cgit v1.2.3