summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2008-05-28 15:55:44 +1000
committerDave Airlie <airlied@redhat.com>2008-06-04 14:08:27 +1000
commit0b734bd7cf921592eee441f759687e10f48a2cbc (patch)
tree3659fe5f86b0a1285ae5a6de592994ba8084074c /configure.ac
parentf688827ebdc7fa8ef1160086565f9e109768a250 (diff)
mesa/drm/ttm: allow build against non-TTM aware libdrm
I'll release a libdrm 2.3.1 without TTM apis included from a special drm branch that should allow mesa 7.1 to build against it. I've had to turn off DRI2 stuff.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a250f75ea5..a73c754dfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -478,6 +478,19 @@ AC_ARG_ENABLE([driglx-direct],
[enable direct rendering in GLX for DRI @<:@default=enabled@:>@])],
[driglx_direct="$enableval"],
[driglx_direct="yes"])
+dnl ttm support
+AC_ARG_ENABLE([ttm-api],
+ [AS_HELP_STRING([--enable-ttm-api],
+ [enable TTM API users])],
+ [ttmapi="$enableval"],
+ [ttmapi="no"])
+
+if test "x$ttmapi" = "xyes"; then
+ save_CFLAGS=$CFLAGS
+ CFLAGS=$LIBDRM_CFLAGS
+ AC_CHECK_HEADERS([xf86mm.h],[],[AC_MSG_ERROR([xf86mm.h required for TTM.])],[#include "stdint.h"\n#include "drm.h"])
+ CFLAGS=$save_CFLAGS
+fi
dnl Which drivers to build - default is chosen by platform
AC_ARG_WITH([dri-drivers],
@@ -516,6 +529,10 @@ if test "$mesa_driver" = dri; then
DEFINES="$DEFINES -DGLX_USE_TLS -DPTHREADS"
fi
+ if test "x$ttmapi" = xyes; then
+ DEFINES="$DEFINES -DTTM_API"
+ fi
+
if test "x$USING_EGL" = x1; then
PROGRAM_DIRS="egl"
fi
@@ -934,6 +951,7 @@ if test "$mesa_driver" = dri; then
dri_dirs=`echo $DRI_DIRS | $SED 's/^ *//;s/ */ /;s/ *$//'`
echo " DRI drivers: $dri_dirs"
echo " DRI driver dir: $DRI_DRIVER_INSTALL_DIR"
+ echo " TTM API support: $ttmapi"
fi
dnl Libraries