summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-01-15 22:52:25 -0800
committerDan Nicholson <dbn.lists@gmail.com>2008-01-15 22:53:18 -0800
commit0c275b6a41294793030d9e380dbcc705264a3768 (patch)
tree30924dda3fb8653741e874923ddf77cab2ce8d33 /configure.ac
parentb039b785e23abb78342fa0febffa0cdbb49e7ef4 (diff)
autoconf: Use -fno-strict-aliasing on GCC
This change adds -fno-strict-aliasing when using gcc and g++, just like the existing configs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a2a2cb46a..89328486b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,9 +66,15 @@ esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -std=c99 -ffast-math"
+
+ # Work around aliasing bugs - developers should comment this out
+ CFLAGS="$CFLAGS -fno-strict-aliasing"
fi
if test "x$GXX" = xyes; then
CXXFLAGS="$CXXFLAGS -Wall"
+
+ # Work around aliasing bugs - developers should comment this out
+ CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
fi
dnl These should be unnecessary, but let the user set them if they want