summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2007-12-12 09:12:15 -0800
committerDan Nicholson <dbn.lists@gmail.com>2007-12-12 09:12:15 -0800
commit16a07fb5569a7e4d471a389f292a8b245fc12cba (patch)
tree9f005be414d6e7d15131d47e8470708da51c6e74 /configure.ac
parent23656c47c9f50c3e074362f2fa857c0ce5ddaf14 (diff)
autoconf: Report the compiler options in the summary
Report the compiler flags and macros that will be used in the build. This just provides a quick way to see what configure has silently been doing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6330cf85e0..94d84ec6c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -804,6 +804,18 @@ else
echo " Demos: $program_dirs"
fi
+dnl Compiler options
+# cleanup the CFLAGS/CXXFLAGS/DEFINES vars
+cflags=`echo $CFLAGS $OPT_FLAGS $PIC_FLAGS $ARCH_FLAGS | \
+ $SED 's/^ *//;s/ */ /;s/ *$//'`
+cxxflags=`echo $CXXFLAGS $OPT_FLAGS $PIC_FLAGS $ARCH_FLAGS | \
+ $SED 's/^ *//;s/ */ /;s/ *$//'`
+defines=`echo $DEFINES $ASM_FLAGS | $SED 's/^ *//;s/ */ /;s/ *$//'`
+echo ""
+echo " CFLAGS: $cflags"
+echo " CXXFLAGS: $cxxflags"
+echo " Macros: $defines"
+
echo ""
echo " Run 'make' to build Mesa"
echo ""