summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2007-12-30 08:41:53 -0800
committerDan Nicholson <dbn.lists@gmail.com>2008-01-11 08:25:15 -0800
commit544ab209e75ec3646d7edbafd736dcf4c93738cc (patch)
treec8642fb334f36e5bd9b552b09e3236bba1b835a3 /configure.ac
parent540faf5f91057ef311999afc5a6366bebe7dec33 (diff)
Allow osmesa to be enabled or disabled
The conditional in src/mesa/Makefile currently hardcodes the cases where libOSMesa can be built on libGL. Likewise, the xlib case always includes libOSMesa in the stand-alone target. This changes the conditional to a loop over the DRIVER_DIRS variable. This means that any driver configuration can enable or disable osmesa. The current "stand-alone" rule is changed so that DRIVER_DIRS=x11 and DRIVER_DIRS="x11 osmesa" are both respected. The configure option is changed to --enable-gl-osmesa as this change allows libOSMesa to be built upon any of the libGL-enabling drivers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 18 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 2acbd67e51..1a2a2cb46a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -523,20 +523,20 @@ dnl
dnl OSMesa configuration
dnl
if test "$mesa_driver" = xlib; then
- default_xlib_osmesa=yes
+ default_gl_osmesa=yes
else
- default_xlib_osmesa=no
+ default_gl_osmesa=no
fi
-AC_ARG_ENABLE(xlib-osmesa,
- [AS_HELP_STRING([--disable-xlib-osmesa],
- [enable OSMesa on Xlib libGL @<:@default=enabled for xlib driver@:>@])],
- xlib_osmesa="$enableval",
- xlib_osmesa="$default_xlib_osmesa")
-if test "x$xlib_osmesa" = xyes; then
- if test "$mesa_driver" = xlib; then
- DRIVER_DIRS="$DRIVER_DIRS osmesa"
+AC_ARG_ENABLE(gl-osmesa,
+ [AS_HELP_STRING([--enable-gl-osmesa],
+ [enable OSMesa on libGL @<:@default=enabled for xlib driver@:>@])],
+ gl_osmesa="$enableval",
+ gl_osmesa="$default_gl_osmesa")
+if test "x$gl_osmesa" = xyes; then
+ if test "$mesa_driver" = osmesa; then
+ AC_MSG_ERROR([libGL is not available for OSMesa driver])
else
- AC_MSG_ERROR([Can only enable OSMesa on libGL for Xlib])
+ DRIVER_DIRS="$DRIVER_DIRS osmesa"
fi
fi
@@ -822,21 +822,17 @@ echo " libdir: $libdir"
dnl Driver info
echo ""
echo " Driver: $mesa_driver"
-case "$mesa_driver" in
-xlib|osmesa)
- if echo "$DRIVER_DIRS" | grep 'osmesa' >/dev/null 2>&1; then
- echo " OSMesa: lib$OSMESA_LIB"
- else
- echo " OSMesa: no"
- fi
- ;;
-dri)
+if echo "$DRIVER_DIRS" | grep 'osmesa' >/dev/null 2>&1; then
+ echo " OSMesa: lib$OSMESA_LIB"
+else
+ echo " OSMesa: no"
+fi
+if test "$mesa_driver" = dri; then
# cleanup the drivers var
dri_dirs=`echo $DRI_DIRS | $SED 's/^ *//;s/ */ /;s/ *$//'`
echo " DRI drivers: $dri_dirs"
echo " DRI driver dir: $DRI_DRIVER_INSTALL_DIR"
- ;;
-esac
+fi
dnl Libraries
echo ""