summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Fogal <tfogal@alumni.unh.edu>2009-08-13 19:40:30 -0600
committerBrian Paul <brianp@vmware.com>2009-08-14 08:58:37 -0600
commit7085dce750f478312a47f474330d63cc900a8448 (patch)
tree6949ef26f5308e24bb8815053e676273ca523be1 /configure.ac
parent66bc17e80e22d8f205cc02171b1c266feab6631f (diff)
Add configure options for MAX_WIDTH/HEIGHT.
This adds two --with configure options for setting defines for MAX_WIDTH and MAX_HEIGHT. It's conceivably just as easy to define these in CFLAGS manually, but this way users don't need to know about internal Mesa details. Patch updated by BrianP to set DEFINES, not CFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9b65d96b39..9d318b3fc2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1159,6 +1159,21 @@ AC_ARG_WITH([xorg-driver-dir],
[XORG_DRIVER_INSTALL_DIR="${libdir}/xorg/modules/drivers"])
AC_SUBST([XORG_DRIVER_INSTALL_DIR])
+AC_ARG_WITH([max-width],
+ [AS_HELP_STRING([--with-max-width=N],
+ [Maximum framebuffer width (4096)])],
+ [DEFINES="${DEFINES} -DMAX_WIDTH=${withval}";
+ AS_IF([test "${withval}" -gt "4096"],
+ [AC_MSG_WARN([Large framebuffer: see s_tritemp.h comments.])])]
+)
+AC_ARG_WITH([max-height],
+ [AS_HELP_STRING([--with-max-height=N],
+ [Maximum framebuffer height (4096)])],
+ [DEFINES="${DEFINES} -DMAX_HEIGHT=${withval}";
+ AS_IF([test "${withval}" -gt "4096"],
+ [AC_MSG_WARN([Large framebuffer: see s_tritemp.h comments.])])]
+)
+
dnl
dnl Gallium Intel configuration
dnl