summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-04-30 13:53:37 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-04-30 14:05:57 -0700
commit7154d661a667681828efb75b3547c97484455d9e (patch)
tree64559f83870830f028edd3a5e8da03ffd254fec1 /configure.ac
parent9a43570f8c8ba5b9803740a47227c296d547631e (diff)
autoconf: Fail from autoconf if the pkg-config macros aren't defined
Instead of postponing the error from missing pkg-config macros to when configure is run, make autoconf exit by using m4 macros.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 43111b3062..672bab85c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,9 +36,14 @@ AC_CHECK_FUNC([dlopen], [],
dnl Make sure the pkg-config macros are defined
m4_ifdef([PKG_PROG_PKG_CONFIG],,[
- AC_MSG_ERROR([The pkg-config autoconf macros are not defined.
- Did you run 'make configure'?])]
-)
+ m4_errprint([Error: Could not locate the pkg-config autoconf macros.
+ These are usually located in /usr/share/aclocal/pkg.m4. If your
+ macros are in a different location, try setting the environment
+ variable ACLOCAL="aclocal -I/other/macro/dir" before running
+ autoreconf.
+])
+ m4_exit([1])
+])
PKG_PROG_PKG_CONFIG()
dnl LIB_DIR - library basename