summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Sapountzis <gsapountzis@gmail.com>2010-03-25 17:01:54 +0200
committerGeorge Sapountzis <gsapountzis@gmail.com>2010-03-25 17:01:54 +0200
commit7b333298fc4efd1a8e44aaebaae77bf88c28ce19 (patch)
tree1ff1cbd6540a717924db16ae7f845b063f176f62 /configure.ac
parent1570e30b487018f056af4d0b5ca83a889f9ce721 (diff)
configure:ac add swrastg_dri
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 1b9500b8b5..4e0ce26849 100644
--- a/configure.ac
+++ b/configure.ac
@@ -474,7 +474,7 @@ xlib)
dri)
SRC_DIRS="$SRC_DIRS glx"
DRIVER_DIRS="dri"
- GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib sw/drm"
+ GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/xlib sw/dri sw/drm"
;;
osmesa)
DRIVER_DIRS="osmesa"
@@ -1409,12 +1409,10 @@ AC_ARG_ENABLE([gallium-swrast],
[build gallium swrast @<:@default=auto@:>@])],
[enable_gallium_swrast="$enableval"],
[enable_gallium_swrast=auto])
-if test "x$enable_gallium_swrast" = xyes; then
- if test "x$enable_egl" != xyes; then
- AC_MSG_ERROR([EGL needs to be enabled for egl-swrast target])
+if test "x$enable_gallium_swrast" = xyes || test "x$enable_gallium_swrast" = xauto; then
+ if test "x$mesa_driver" = xdri; then
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS dri-swrast"
fi
- GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS egl-swrast"
-elif test "x$enable_gallium_swrast" = xauto; then
if test "x$enable_egl" = xyes; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS egl-swrast"
fi