summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2008-10-28 18:56:05 +0100
committerDan Nicholson <dbn.lists@gmail.com>2008-10-28 11:45:05 -0700
commit98fcdf3f49aea14b4dd4f4b83c956f8a117020c9 (patch)
tree497b2ae14ea245edabe040af07c30d1f2e609c88 /configure.ac
parentbcfba0d91e51290b1a957a1861ec0b18899feb92 (diff)
configure.ac: Add support for gnu/kfreebsd
Check for *-gnu instead of linux* to set DEFINES. Change some freebsd* checks to *freebsd*.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 463821be6c..e48137f2ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,7 +83,7 @@ dnl Compiler macros
DEFINES=""
AC_SUBST([DEFINES])
case "$host_os" in
-linux*)
+*-gnu)
if test "x$GCC" = xyes; then
DEFINES="$DEFINES -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_BSD_SOURCE"
fi
@@ -271,14 +271,14 @@ if test "x$enable_asm" = xyes; then
case "$host_cpu" in
i?86)
case "$host_os" in
- linux* | freebsd* | dragonfly*)
+ linux* | *freebsd* | dragonfly*)
test "x$enable_64bit" = xyes && asm_arch=x86_64 || asm_arch=x86
;;
esac
;;
x86_64)
case "$host_os" in
- linux* | freebsd* | dragonfly*)
+ linux* | *freebsd* | dragonfly*)
test "x$enable_32bit" = xyes && asm_arch=x86 || asm_arch=x86_64
;;
esac
@@ -368,7 +368,7 @@ linux*)
i*86|x86_64|powerpc*) default_driver="dri";;
esac
;;
-freebsd* | dragonfly*)
+*freebsd* | dragonfly*)
case "$host_cpu" in
i*86|x86_64) default_driver="dri";;
esac