summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-07-01 09:03:15 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-07-11 10:04:46 -0700
commit99803a4ec90d70363305c0652203550d63f086ec (patch)
tree9597196cedb80de225db9d1b639d59b77ffa7606 /configure.ac
parente97ab72b593278edeac9f9b71b8237a79247c7c7 (diff)
autoconf: Add information about the --x-* options to --help output
Try to tell the user that the --x-* options are only used when the X libraries can't be found by pkg-config.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dbd81909f1..ec8b5ddbc7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -456,7 +456,7 @@ esac
dnl
dnl Find out if X is available. The variable have_x is set if libX11 is
-dnl to mimic AC_PATH_XTRA.
+dnl found to mimic AC_PATH_XTRA.
dnl
if test -n "$PKG_CONFIG"; then
AC_MSG_CHECKING([pkg-config files for X11 are available])
@@ -475,6 +475,12 @@ if test "$x11_pkgconfig" = no; then
AC_PATH_XTRA
fi
+dnl Try to tell the user that the --x-* options are only used when
+dnl pkg-config is not available. This must be right after AC_PATH_XTRA.
+m4_divert_once([HELP_BEGIN],
+[These options are only used when the X libraries cannot be found by the
+pkg-config utility.])
+
dnl We need X for xlib and dri, so bomb now if it's not found
case "$mesa_driver" in
xlib|dri)