summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2007-12-11 08:21:51 -0800
committerDan Nicholson <dbn.lists@gmail.com>2007-12-11 08:24:27 -0800
commitaab38cfc43581e0d09195c2e53092d355a09841c (patch)
tree5f3bc0ce082ae750724ccc37262ac0df3473adbc /configure.ac
parent78175579c26498b1ef0edc511855ae74b7c3b52b (diff)
autoconf: Replace configs/current symlink from configure
Rather than having the user run `make autoconf' and have the Makefile setup the configs/current -> autoconf symlink, we can just do that in configure. This allows the user to just run `make' to build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 00e008af3c..4cd641b136 100644
--- a/configure.ac
+++ b/configure.ac
@@ -730,6 +730,12 @@ CPPFLAGS="$_SAVE_CPPFLAGS"
dnl Substitute the config
AC_OUTPUT([configs/autoconf])
+dnl Replace the configs/current symlink
+if test -f configs/current || test -L configs/current; then
+ rm -f configs/current
+fi
+ln -s autoconf configs/current
+
dnl
dnl Output some configuration info for the user
dnl
@@ -775,5 +781,5 @@ else
fi
echo ""
-echo " Run 'make autoconf' to build Mesa"
+echo " Run 'make' to build Mesa"
echo ""