summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2007-12-26 11:12:29 -0600
committerDan Nicholson <dbn.lists@gmail.com>2007-12-26 15:38:30 -0600
commitab57cbaccccb30fd743ba3283251430e6bc3a071 (patch)
tree02898c2b71f76ef6e162c80f9c2f7381221d156a /configure.ac
parent4c5a2b3af214e7a0ec0742b17beb1e719552ecae (diff)
autoconf: Helper options for adding GCC 32/64 bit flags
Two new configure options to add -m32 or -m64 to the CFLAGS and CXXFLAGS when GCC is in use. By default, the user supplied options are environment variables are respected, but these options are quick helps for the common case of x86/x86_64 using GCC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f2f2d75a1a..2acbd67e51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,6 +80,38 @@ AC_SUBST(OPT_FLAGS)
AC_SUBST(ARCH_FLAGS)
dnl
+dnl Hacks to enable 32 or 64 bit build
+dnl
+AC_ARG_ENABLE(32-bit,
+ [AS_HELP_STRING([--enable-32-bit],
+ [build 32-bit libraries @<:@default=auto@:>@])],
+ enable_32bit="$enableval",
+ enable_32bit=auto
+)
+if test "x$enable_32bit" = xyes; then
+ if test "x$GCC" = xyes; then
+ CFLAGS="$CFLAGS -m32"
+ fi
+ if test "x$GXX" = xyes; then
+ CXXFLAGS="$CXXFLAGS -m32"
+ fi
+fi
+AC_ARG_ENABLE(64-bit,
+ [AS_HELP_STRING([--enable-64-bit],
+ [build 64-bit libraries @<:@default=auto@:>@])],
+ enable_64bit="$enableval",
+ enable_64bit=auto
+)
+if test "x$enable_64bit" = xyes; then
+ if test "x$GCC" = xyes; then
+ CFLAGS="$CFLAGS -m64"
+ fi
+ if test "x$GXX" = xyes; then
+ CXXFLAGS="$CXXFLAGS -m64"
+ fi
+fi
+
+dnl
dnl shared/static libraries, mimic libtool options
dnl
AC_ARG_ENABLE(static,