summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-05-22 09:39:02 -0700
committerDan Nicholson <dbn.lists@gmail.com>2009-06-01 06:32:52 -0700
commitbc302b2a33ceffe454bcf443daa0ac1edc118e9b (patch)
treeb3ef47e16a5479963a12bf2585cadfa54539d035 /configure.ac
parent85e0572756b85b7025740fbbefb673cf75a46cea (diff)
Use separate $(MINSTALL) for installing libraries
The special feature of bin/minstall to copy symlinks is only ever needed when installing libraries which may have .so symlinks. All the headers and directories can use a normal install program. These two modes are separated as $(INSTALL) and $(MINSTALL) to allow the user (or autoconf) to override installing normal files as they please. An autoconf check for the install program has been added and will be used in preference to minstall when available. Fixes bug 16053.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 24aa13a7ca..772fb29973 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,11 @@ AC_CHECK_PROGS([MAKE], [gmake make])
AC_PATH_PROG([MKDEP], [makedepend])
AC_PATH_PROG([SED], [sed])
+dnl Our fallback install-sh is a symlink to minstall. Use the existing
+dnl configuration in that case.
+AC_PROG_INSTALL
+test "x$INSTALL" = "x$ac_install_sh" && INSTALL='$(MINSTALL)'
+
dnl We need a POSIX shell for parts of the build. Assume we have one
dnl in most cases.
case "$host_os" in