summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2008-02-25 18:50:26 -0500
committerKristian Høgsberg <krh@redhat.com>2008-02-25 19:02:07 -0500
commitbcecea6ea6c2727e4071f5a43fab49673573e905 (patch)
treeccee9ba7972f3a260976e967a9f15cedb76846e1 /configure.ac
parent7381ccab449c65d843580f76426f87ab6b1649ce (diff)
autoconf: Add gcc search patch to MKDEP_OPTIONS to eliminate warnings.
Also, use -include to avoid error message when make initially fails to include the non-existent depend file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7707f8a8e..ec1bb8288e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,15 @@ AC_PATH_PROG(MAKE, make)
AC_PATH_PROG(MKDEP, makedepend)
AC_PATH_PROG(SED, sed)
+dnl Ask gcc where it's keeping its secret headers
+if test "x$GCC" = xyes; then
+ GCC_PATH=$(gcc -print-search-dirs | sed -ne 's/install: //p')
+ MKDEP_OPTIONS="-fdepend -I${GCC_PATH}include"
+else
+ MKDEP_OPTIONS=-fdepend
+fi
+AC_SUBST(MKDEP_OPTIONS)
+
dnl Make sure the pkg-config macros are defined
m4_ifdef([PKG_PROG_PKG_CONFIG],,[
AC_MSG_ERROR([The pkg-config autoconf macros are not defined.