summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-03-22 11:03:16 -0700
committerEric Anholt <eric@anholt.net>2008-03-22 11:03:16 -0700
commitc98642169496cfa7d8026dbd5214fafbde962002 (patch)
tree55ba18a4f569112d78d5664a92f09af714baa518 /configure.ac
parentdc6fab90b437ed7f03f5cb239d3251b5b4f2cd56 (diff)
autoconf: Add a workaround for second AC_PROG_PATH not overwriting results.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 99657eb20a..8b79342e45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,9 +26,10 @@ dnl Check for progs
AC_PROG_CPP
AC_PROG_CC
AC_PROG_CXX
-AC_PATH_PROG(MAKE, gmake, [not_found])
-if test "x$MAKE" = "xnot_found"; then
- AC_PATH_PROG(MAKE, make)
+AC_PATH_PROG(GMAKE, gmake, [not_found])
+AC_PATH_PROG(MAKE, make)
+if test "x$GMAKE" != "xnot_found"; then
+ MAKE="$GMAKE"
fi
AC_PATH_PROG(MKDEP, makedepend)
AC_PATH_PROG(SED, sed)