summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2010-03-15 20:53:56 -0700
committerDan Nicholson <dbn.lists@gmail.com>2010-03-23 13:26:50 -0700
commite725ef171b5a4d5425461f237d9ccab223806913 (patch)
treeeaadc7d655afd1cbd445ef58e549b72b74fe61fe /configure.ac
parentba5a53edd12fac24c176e714560b1f9ec255bbdb (diff)
Change libX11 variables to not conflict with AC_PATH_XTRA
The variable X_LIBS from AC_PATH_XTRA contains only the -L searchdir parameter and not the -lX11 to link to Xlib. Use X11 prefixed build vars for linking with Xlib to avoid the conflict. Signed-off-by: Dan Nicholson <dbn.lists@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0f51097ef6..26960e85ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -548,9 +548,13 @@ else
fi
dnl Use the autoconf macro if no pkg-config files
if test "$x11_pkgconfig" = yes; then
- PKG_CHECK_MODULES([X], [x11])
+ PKG_CHECK_MODULES([X11], [x11])
else
AC_PATH_XTRA
+ test -z "$X11_CFLAGS" && X11_CFLAGS="$X_CFLAGS"
+ test -z "$X11_LIBS" && X11_LIBS="$X_LIBS -lX11"
+ AC_SUBST([X11_CFLAGS])
+ AC_SUBST([X11_LIBS])
fi
dnl Try to tell the user that the --x-* options are only used when