summaryrefslogtreecommitdiff
path: root/docs/MESA_copy_sub_buffer.spec
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2009-01-09 18:28:38 -0800
committerIan Romanick <ian.d.romanick@intel.com>2009-01-13 12:36:03 -0800
commit1f47388dfebf15f610993f046e1f945024c8fc3c (patch)
treedecfc74d917061a259bd0742c74a4d24fd948349 /docs/MESA_copy_sub_buffer.spec
parent34500a6da565f769e55babc6d28c14f606e2d52a (diff)
Add language about implicit flush and command completion
Copied language from the glXSwapBuffers manual page about the implicit glFlush and expected command completion. This just codifies what people already expect from glXCopySubBufferMESA. The intention of this command is to work like glXSwapBuffers but on a sub-rectangle of the drawable. Acked-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'docs/MESA_copy_sub_buffer.spec')
-rw-r--r--docs/MESA_copy_sub_buffer.spec12
1 files changed, 10 insertions, 2 deletions
diff --git a/docs/MESA_copy_sub_buffer.spec b/docs/MESA_copy_sub_buffer.spec
index 43424a5f46..752a014b35 100644
--- a/docs/MESA_copy_sub_buffer.spec
+++ b/docs/MESA_copy_sub_buffer.spec
@@ -16,7 +16,7 @@ Status
Version
- Last Modified Date: 8 June 2000
+ Last Modified Date: 12 January 2009
Number
@@ -69,6 +69,12 @@ Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors)
<width> and <height> indicate the size in pixels. Coordinate (0,0)
corresponds to the lower-left pixel of the window, like glReadPixels.
+ If dpy and drawable are the display and drawable for the calling
+ thread's current context, glXCopySubBufferMESA performs an
+ implicit glFlush before it returns. Subsequent OpenGL commands
+ may be issued immediately after calling glXCopySubBufferMESA, but
+ are not executed until the copy is completed.
+
GLX Protocol
None at this time. The extension is implemented in terms of ordinary
@@ -84,5 +90,7 @@ New State
Revision History
- 8 June 2000 - initial specification
+ 12 January 2009 Ian Romanick - Added language about implicit flush
+ and command completion.
+ 8 June 2000 Brian Paul - initial specification