summaryrefslogtreecommitdiff
path: root/docs/MESA_release_buffers.spec
diff options
context:
space:
mode:
authorBrian Paul <brian.paul@tungstengraphics.com>2000-06-09 00:22:02 +0000
committerBrian Paul <brian.paul@tungstengraphics.com>2000-06-09 00:22:02 +0000
commit7b2c0f9148eb7eb30326173899ed366fcef8d437 (patch)
tree17bde65a25c3eaf0feaf1f5dbd06043626e28386 /docs/MESA_release_buffers.spec
parent4c07bd5709830bd11cb29d4d8b8a56e757dc0365 (diff)
initial check-in
Diffstat (limited to 'docs/MESA_release_buffers.spec')
-rw-r--r--docs/MESA_release_buffers.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/docs/MESA_release_buffers.spec b/docs/MESA_release_buffers.spec
new file mode 100644
index 0000000000..f27ffaa9bc
--- /dev/null
+++ b/docs/MESA_release_buffers.spec
@@ -0,0 +1,85 @@
+Name
+
+ MESA_release_buffers
+
+Name Strings
+
+ GLX_MESA_release_buffers
+
+Contact
+
+ Brian Paul (brian 'at' mesa3d.org)
+
+Status
+
+ Shipping since Mesa 2.0 in October, 1996.
+
+Version
+
+ Last Modified Date: 8 June 2000
+
+Number
+
+ ???
+
+Dependencies
+
+ OpenGL 1.0 or later is required.
+ GLX 1.0 or later is required.
+
+Overview
+
+ Mesa's implementation of GLX is entirely implemented on the client side.
+ Therefore, Mesa cannot immediately detect when an X window or pixmap is
+ destroyed in order to free any ancilliary data associated with the window
+ or pixmap.
+
+ The glxMesaReleaseBuffers() function can be used to explicitly indicate
+ when the back color buffer, depth buffer, stencil buffer, and/or accum-
+ ulation buffer associated with a drawable can be freed.
+
+IP Status
+
+ Open-source; freely implementable.
+
+Issues
+
+ None.
+
+New Procedures and Functions
+
+ Bool glXReleaseBuffersMESA( Display *dpy, GLXDrawable d );
+
+New Tokens
+
+ None.
+
+Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors)
+
+ The function
+
+ Bool glXReleaseBuffersMESA( Display *dpy, GLXDrawable d );
+
+ causes all software ancilliary buffers (back buffer, depth, stencil,
+ accum, etc) associated with the named drawable to be immediately
+ deallocated. True is returned if <d> is a valid Mesa GLX drawable,
+ else False is returned. After calling glXReleaseBuffersMESA, the
+ drawable should no longer be used for GL rendering. Results of
+ attempting to do so are undefined.
+
+
+GLX Protocol
+
+ None, since this is a client-side operation.
+
+Errors
+
+ None.
+
+New State
+
+ None.
+
+Revision History
+
+ 8 June 2000 - initial specification