summaryrefslogtreecommitdiff
path: root/docs/MESA_swap_control.spec
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2010-02-04 16:15:45 -0800
committerIan Romanick <ian.d.romanick@intel.com>2010-02-11 15:40:29 -0800
commit68fef184390da2fd67acfd99fba0a2dbe4a3b875 (patch)
treefe0507dbbf9607dcf9bcd7e69dbbd78f795bb781 /docs/MESA_swap_control.spec
parent1add5354d0fbfb2d9b6a4a3fd6a39225bcadc098 (diff)
glx: Fix interval test in glXSwapIntervalMESA
It appears that, in spite of what the spec says, the interval parameter to glXSwapIntervalMESA has been an unsigned int since day-1. This made the 'if (interval < 0)' test useless. The test is removed and the spec is updated to note that the interval is an unsigned value.
Diffstat (limited to 'docs/MESA_swap_control.spec')
-rw-r--r--docs/MESA_swap_control.spec7
1 files changed, 2 insertions, 5 deletions
diff --git a/docs/MESA_swap_control.spec b/docs/MESA_swap_control.spec
index ecc674649e..856978b535 100644
--- a/docs/MESA_swap_control.spec
+++ b/docs/MESA_swap_control.spec
@@ -43,7 +43,7 @@ Issues
New Procedures and Functions
- int glXSwapIntervalMESA(int interval)
+ int glXSwapIntervalMESA(unsigned int interval)
int glXGetSwapIntervalMESA(void)
New Tokens
@@ -103,11 +103,8 @@ Additions to the GLX 1.3 Specification
Errors
- glXSwapIntervalMESA returns GLX_BAD_VALUE if parameter <interval> is
- less than zero.
-
glXSwapIntervalMESA returns GLX_BAD_CONTEXT if there is no current
- GLXContext.
+ GLXContext or if the current context is not a direct rendering context.
GLX Protocol