summaryrefslogtreecommitdiff
path: root/docs/MESA_swap_control.spec
diff options
context:
space:
mode:
authorBrian Paul <brian.paul@tungstengraphics.com>2003-05-02 15:04:20 +0000
committerBrian Paul <brian.paul@tungstengraphics.com>2003-05-02 15:04:20 +0000
commitc784d87b0f07590a2bb87307ca6a264b2ec99b31 (patch)
tree85fa1c75ae6918f0cab241c6558ea7e7606349a1 /docs/MESA_swap_control.spec
parente53aa5022f5d70abe81d5b97dccebcb389cf4647 (diff)
updates from Ian
Diffstat (limited to 'docs/MESA_swap_control.spec')
-rw-r--r--docs/MESA_swap_control.spec27
1 files changed, 21 insertions, 6 deletions
diff --git a/docs/MESA_swap_control.spec b/docs/MESA_swap_control.spec
index e05d515496..ecc674649e 100644
--- a/docs/MESA_swap_control.spec
+++ b/docs/MESA_swap_control.spec
@@ -8,7 +8,7 @@ Name Strings
Contact
- Ian Romanick, IBM (idr 'at' us.ibm.com)
+ Ian Romanick, IBM, idr at us.ibm.com
Status
@@ -16,7 +16,7 @@ Status
Version
- Date: 3/17/2003 Revision: 1.0
+ Date: 5/1/2003 Revision: 1.1
Number
@@ -34,6 +34,13 @@ Overview
This extension allows an application to specify a minimum periodicity
of color buffer swaps, measured in video frame periods.
+Issues
+
+ * Should implementations that export GLX_MESA_swap_control also export
+ GL_EXT_swap_control for compatibility with WGL_EXT_swap_control?
+
+ UNRESOLVED.
+
New Procedures and Functions
int glXSwapIntervalMESA(int interval)
@@ -89,10 +96,10 @@ Additions to the GLX 1.3 Specification
The swap interval is not part of the render context state. It cannot
be pushed or popped. The current swap interval for the window
associated with the current context can be obtained by calling
- glXGetSwapIntervalMESA. The default swap interval is 1.
+ glXGetSwapIntervalMESA. The default swap interval is 0.
- On XFree86, setting the environment variable LIBGL_NO_VSYNC sets the
- swap interval to 0.
+ On XFree86, setting the environment variable LIBGL_THROTTLE_REFRESH sets
+ the swap interval to 1.
Errors
@@ -110,8 +117,16 @@ New State
Get Value Get Command Type Initial Value
--------- ----------- ---- -------------
- [swap interval] GetSwapInterval Z+ 1
+ [swap interval] GetSwapInterval Z+ 0
New Implementation Dependent State
None
+
+
+Revision History
+
+ 1.1, 5/1/03 Added the issues section and contact information.
+ Changed the default swap interval to 0.
+ 1.0, 3/17/03 Initial version based on GLX_SGI_swap_control and
+ WGL_EXT_swap_control.