summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 3 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index cccf7bd44d..e57f7b7de6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -879,21 +879,9 @@ AC_SUBST([ASM_FLAGS])
AC_SUBST([ASM_SOURCES])
AC_SUBST([ASM_API])
-PIC_FLAGS=""
-case "$host_os" in
-linux*)
- PIC_FLAGS="-fPIC"
- ;;
-freebsd* | dragonfly*)
- PIC_FLAGS="-fPIC"
- case "$host_cpu" in
- i?86)
- PIC_FLAGS=""
- ;;
- esac
- ;;
-esac
-AC_SUBST([PIC_FLAGS])
+dnl PIC code macro
+MESA_PIC_FLAGS
+
dnl Restore LDFLAGS and CPPFLAGS
LDFLAGS="$_SAVE_LDFLAGS"