summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-10-02 21:36:49 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-10-02 21:36:49 +0000
commit05195c3d000f080bc3103850158387578f7c2242 (patch)
tree018796092e8ced6db8294a18fda59826fe8f8315
parentf393387661ce72dbf6a2271e24c64a5a535bb752 (diff)
- default to mips I for mipsel and mips III for mips
- suggest some target flags for abi64
-rw-r--r--package/Makefile.in4
-rw-r--r--target/Config.in.arch6
2 files changed, 9 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 0c2abcb1d..903f46d6d 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -51,6 +51,10 @@ ifeq ($(findstring y,$(BR2_sparc_v9a)$(BR2_sparc64_v9a)$(BR2_sparc_v9b)$(BR2_spa
TARGET_CFLAGS+=-mvis
endif
+ifeq ($(findstring yy,$(BR2_mips)$(BR2_MIPS_ABI64)),yy)
+TARGET_CFLAGS+=-fno-pic -mno-abicalls
+endif
+
TARGET_CXXFLAGS=$(TARGET_CFLAGS)
# else it's an external toolchain
diff --git a/target/Config.in.arch b/target/Config.in.arch
index 367dd59b4..d764b62dd 100644
--- a/target/Config.in.arch
+++ b/target/Config.in.arch
@@ -124,9 +124,13 @@ endchoice
choice
prompt "Target Architecture Variant"
depends BR2_mips || BR2_mipsel
- default BR2_mips_3
+ default BR2_mips_3 if BR2_mips
+ default BR2_mips_1 if BR2_mipsel
help
Specific CPU variant to use
+
+ 64bit cabable: 3, 4, 64, 64r2
+ non-64bit capable: 1, 2, 32, 32r2
config BR2_mips_1
bool "mips I (generic)"