summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-02 20:31:01 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-02 20:31:01 +0000
commit3db839986d264948700322b8d27c6d99b0c7d6f4 (patch)
tree1d138821946493ed760a888db8ff7a276ac01ba8
parent31de8c37dacbc798a0e94606192818ff02686153 (diff)
toolchain: revert "Allow creating a script for external use of Buildroot toolchain"
It's been 10 days now without any reply from Ulf, so revert r24480+r24481.
-rw-r--r--toolchain/Config.in2
-rw-r--r--toolchain/Makefile.in2
-rw-r--r--toolchain/export-toolchain/Config.in8
-rw-r--r--toolchain/export-toolchain/Makefile.in29
-rw-r--r--toolchain/uClibc/Config.in6
5 files changed, 0 insertions, 47 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index b0eb85dac..d66ce1d38 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -26,8 +26,6 @@ config BR2_TOOLCHAIN_SOURCE
default y if BR2_TOOLCHAIN_BUILDROOT || BR2_TOOLCHAIN_EXTERNAL_SOURCE
default n if BR2_TOOLCHAIN_EXTERNAL
-source "toolchain/export-toolchain/Config.in"
-
source "target/device/Config.in.toolchain"
source "toolchain/Config.in.1"
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 8469baccf..d312b5642 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -46,5 +46,3 @@ CFLAGS_COMBINE = $(call cc-option,-combine,)
# gcc has a bunch of needed stuff....
include toolchain/gcc/Makefile.in
-# breaks the build
-#include toolchain/export-toolchain/Makefile.in
diff --git a/toolchain/export-toolchain/Config.in b/toolchain/export-toolchain/Config.in
deleted file mode 100644
index 1de8dcb5b..000000000
--- a/toolchain/export-toolchain/Config.in
+++ /dev/null
@@ -1,8 +0,0 @@
-config BR2_EXPORT_TOOLCHAIN
- bool "Create script exporting toolchain to home directory"
- default n
- help
- This will generate a batchfile which, if run
- will add the Buildroot toolchain to the user PATH
- The file is called "$(ARCH)-uclibc-gcc-$(GCC_VERSION).sh"
-
diff --git a/toolchain/export-toolchain/Makefile.in b/toolchain/export-toolchain/Makefile.in
deleted file mode 100644
index 38fea95e9..000000000
--- a/toolchain/export-toolchain/Makefile.in
+++ /dev/null
@@ -1,29 +0,0 @@
-# This generates a script which exports the toolchain
-# using a shell script
-
-GCC_SCRIPT:=$(ARCH)-uclibc-gcc-$(GCC_VERSION).sh
-GCC_SCRIPT_TEMP:=$(BINARIES_DIR)/$(GCC_SCRIPT)
-
-~/$(GCC_SCRIPT): cross_compiler
- @echo "#!/bin/sh" > $(GCC_SCRIPT_TEMP)
- @echo "# $(ARCH) cross compiler toolchain created $(DATE)" >> $(GCC_SCRIPT_TEMP)
- @echo "# gcc-$(GCC_VERSION)" >> $(GCC_SCRIPT_TEMP)
- @echo "# binutils-$(BINUTILS_VERSION)" >> $(GCC_SCRIPT_TEMP)
- @echo "# uClibc-$(UCLIBC_VERSION)" >> $(GCC_SCRIPT_TEMP)
- @echo "export GCCROOT=$(STAGING_DIR)/usr" >> $(GCC_SCRIPT_TEMP)
- @echo "export PATH=\$$PATH:\$$GCCROOT/bin" >> $(GCC_SCRIPT_TEMP)
- @echo "export CROSS_COMPILE=$(REAL_GNU_TARGET_NAME)-" >> $(GCC_SCRIPT_TEMP)
- @chmod a+x $(GCC_SCRIPT_TEMP)
- @cp $(GCC_SCRIPT_TEMP) ~/$(GCC_SCRIPT)
- @cat ~/$(GCC_SCRIPT)
-
-export-toolchain: ~/$(GCC_SCRIPT)
-
-export-toolchain-clean:
- rm -f ~/$(GCC_SCRIPT)
- rm -f $(GCC_SCRIPT_TEMP)
-
-ifeq ($(BR2_EXPORT_TOOLCHAIN),y)
-TARGETS+=export-toolchain
-endif
-
diff --git a/toolchain/uClibc/Config.in b/toolchain/uClibc/Config.in
index fac4dfa0d..254c33e43 100644
--- a/toolchain/uClibc/Config.in
+++ b/toolchain/uClibc/Config.in
@@ -27,12 +27,6 @@ choice
endchoice
-config UCLIBC_VERSION
- string
- default "0.9.28.3" if BR2_UCLIBC_VERSION_0_9_28_3
- default "0.9.29" if BR2_UCLIBC_VERSION_0_9_29
- default "0.9.30" if BR2_UCLIBC_VERSION_0_9_30
- default "snapshot" if BR2_UCLIBC_VERSION_SNAPSHOT
config BR2_USE_UCLIBC_SNAPSHOT
string "Date (yyyymmdd) of snapshot or 'snapshot' for latest"