summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-06-28 03:13:23 +0000
committerEric Andersen <andersen@codepoet.org>2003-06-28 03:13:23 +0000
commit55b2ef0fc21c525856bf0379988b0c0475209c03 (patch)
tree5fedf074bec0a2a3073e53921702fdb705753cd4
parent13694747348a4107a49b6b2780f4627ce77bc76c (diff)
Strip the perl binary
-rw-r--r--make/perl.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/make/perl.mk b/make/perl.mk
index 2e1a92522..f76a178d3 100644
--- a/make/perl.mk
+++ b/make/perl.mk
@@ -41,6 +41,10 @@ $(TARGET_DIR)/$(PERL_TARGET_BINARY): $(PERL_DIR)/$(PERL_BINARY)
rm -f $(PERL_DIR)/install_me_here/usr/lib/perl/5.8.0/ExtUtils/MANIFEST.SKIP
rm -f $(PERL_DIR)/install_me_here/usr/lib/perl/5.8.0/unicore/Makefile
rm -rf $(TARGET_DIR)/usr/lib/perl
+ -$(STRIP) $(PERL_DIR)/install_me_here/usr/bin/a2p
+ -$(STRIP) $(PERL_DIR)/install_me_here/usr/bin/perl
+ rm -f $(PERL_DIR)/install_me_here/usr/bin/perl5.8.0
+ (cd $(PERL_DIR)/install_me_here/usr/bin; ln -sf perl perl5.8.0)
cp -fa $(PERL_DIR)/install_me_here/* $(TARGET_DIR)/
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc