summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-07-16 14:16:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-07-16 14:16:25 +0200
commit6c243d12d96b76136e334a8e51e8c41cb1d782b2 (patch)
treea7eaa0d1d76cfe5822e6999f394971480c00890c
parentea536503331aea875e84ae598b4610fbd059f167 (diff)
qtopia4: add option for STL support
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/qtopia4/Config.in6
-rw-r--r--package/qtopia4/qtopia4.mk7
2 files changed, 12 insertions, 1 deletions
diff --git a/package/qtopia4/Config.in b/package/qtopia4/Config.in
index 052431257..457b9399a 100644
--- a/package/qtopia4/Config.in
+++ b/package/qtopia4/Config.in
@@ -310,6 +310,12 @@ config BR2_PACKAGE_QTOPIA4_WEBKIT
Build the WebKit module.
If unsure, say n.
+config BR2_PACKAGE_QTOPIA4_STL
+ bool "STL support"
+ help
+ Compile STL support.
+ If unsure, say n.
+
config BR2_PACKAGE_QTOPIA4_OPENSSL
bool "Enable OpenSSL support"
depends on BR2_PACKAGE_QTOPIA4_NETWORK
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index f7196f476..0d2b980e9 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -323,6 +323,12 @@ else
QTOPIA4_CONFIGURE+= -no-webkit
endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_STL),y)
+QTOPIA4_CONFIGURE+= -stl
+else
+QTOPIA4_CONFIGURE+= -no-stl
+endif
+
QTOPIA4_CONFIGURE:=$(strip $(subst ",, $(QTOPIA4_CONFIGURE)))
#"))
BR2_PACKAGE_QTOPIA4_EMB_PLATFORM:=$(strip $(subst ",, $(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM)))
@@ -460,7 +466,6 @@ endif
-embedded $(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM) \
$(QTOPIA4_QCONFIG_COMMAND) \
$(QTOPIA4_CONFIGURE) \
- -no-stl \
-no-cups \
-no-nis \
-no-accessibility \