summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-05-06 09:09:58 +0000
committerEric Andersen <andersen@codepoet.org>2004-05-06 09:09:58 +0000
commit6fb11d57cf6f02bf4e9186d3264b86122b7dd52c (patch)
tree1d29c98f16c6d89e3ebd8149770db7c7403a31c2
parent7037120431a6329522ed0c17a70a5218bf3b38ba (diff)
be sure the dir is present
-rw-r--r--make/sed.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/make/sed.mk b/make/sed.mk
index 71546ca5c..2476c59aa 100644
--- a/make/sed.mk
+++ b/make/sed.mk
@@ -53,6 +53,7 @@ build-sed-host-binary: $(SED_DIR1)/$(SED_BINARY)
@if [ ! -f $(STAGING_DIR)/$(SED_TARGET_BINARY) -o $(STAGING_DIR)/$(SED_TARGET_BINARY) \
-ot $(SED_DIR1)/$(SED_BINARY) ] ; then \
set -x; \
+ mkdir -p $(STAGING_DIR)/bin; \
$(MAKE) DESTDIR=$(STAGING_DIR) -C $(SED_DIR1) install; \
mv $(STAGING_DIR)/usr/bin/sed $(STAGING_DIR)/bin/; \
rm -rf $(STAGING_DIR)/share/locale $(STAGING_DIR)/usr/info \