summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-27 14:11:53 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-27 14:11:53 +0200
commit978a88c4159116a3fbc5db42c2055f3cdc2ad99e (patch)
tree8781c164e69d55ec73869c8d9c35c6d4b22e7e1c
parentaacfa1803358fa97afc3e2423956d97a9292d60d (diff)
parentbeafd2073059499f612cf6e68b2228b87c0325c6 (diff)
Merge branch 'pkg-stats-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
-rwxr-xr-xscripts/pkg-stats27
1 files changed, 13 insertions, 14 deletions
diff --git a/scripts/pkg-stats b/scripts/pkg-stats
index 0ed420d32..1174ef04c 100755
--- a/scripts/pkg-stats
+++ b/scripts/pkg-stats
@@ -70,7 +70,7 @@ for i in $(find package/ -name '*.mk') ; do
$i = "package/database/database.mk" -o \
$i = "package/editors/editors.mk" -o \
$i = "package/games/games.mk" -o \
- $i = "package/multimedia/multimedia" -o \
+ $i = "package/multimedia/multimedia.mk" -o \
$i = "package/customize/customize.mk" -o \
$i = "package/gnuconfig/gnuconfig.mk" -o \
$i = "package/x11r7/x11r7.mk" ; then
@@ -144,7 +144,7 @@ for i in $(find package/ -name '*.mk') ; do
echo "</td>"
echo "<td class=\"centered\">"
- if grep "^$pkg:" $i > /dev/null ; then
+ if test $is_pkg_target -eq 0 -a $is_auto_target -eq 0 ; then
found=1
is_manual_target=1
echo "<b>YES</b>"
@@ -155,18 +155,17 @@ for i in $(find package/ -name '*.mk') ; do
echo "<td>"
echo "<ul>"
- if [ $is_manual_target -eq 1 ]; then
- echo "<li>convert to generic target</li>"
- convert_to_generic_target=$((convert_to_generic_target+1))
- fi
- if [ $is_manual_host -eq 1 ]; then
- echo "<li>convert to generic host</li>"
- convert_to_generic_host=$((convert_to_generic_host+1))
- fi
- if grep "\./configure" $i > /dev/null ; then
- if [ $is_manual_host -ne 1 ] ; then
- echo "<li>convert package to autotools ?</li>"
- convert_to_autotools=$((convert_to_autotools+1))
+ if grep "/configure" $i > /dev/null ; then
+ echo "<li>convert package to autotools ?</li>"
+ convert_to_autotools=$((convert_to_autotools+1))
+ else
+ if [ $is_manual_target -eq 1 ]; then
+ echo "<li>convert to generic target</li>"
+ convert_to_generic_target=$((convert_to_generic_target+1))
+ fi
+ if [ $is_manual_host -eq 1 ]; then
+ echo "<li>convert to generic host</li>"
+ convert_to_generic_host=$((convert_to_generic_host+1))
fi
fi
if [ $found -eq 0 ] ; then