summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-11 15:43:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-31 20:28:21 +0200
commit97d8618c6cc2970ea5870ae214344b3bff083883 (patch)
tree26d1450015867195930dac11ede8c234544ea7b8
parent343f480fe2647febe7fc713722d1131242ba20e3 (diff)
Remove code specific to removed architectures
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--fs/jffs2/Config.in4
-rw-r--r--package/liboil/liboil.mk3
-rw-r--r--package/ltrace/Config.in2
-rw-r--r--package/openssl/openssl.mk3
-rw-r--r--toolchain/gcc/Config.in2
-rw-r--r--toolchain/toolchain-common.in1
6 files changed, 4 insertions, 11 deletions
diff --git a/fs/jffs2/Config.in b/fs/jffs2/Config.in
index b787ec9d1..de1376881 100644
--- a/fs/jffs2/Config.in
+++ b/fs/jffs2/Config.in
@@ -95,10 +95,10 @@ config BR2_TARGET_ROOTFS_JFFS2_PADSIZE
choice
prompt "Endianess"
- default BR2_TARGET_ROOTFS_JFFS2_BE if BR2_alpha || BR2_armeb || \
+ default BR2_TARGET_ROOTFS_JFFS2_BE if BR2_armeb || \
BR2_avr32 || BR2_m68k || BR2_mips || \
BR2_powerpc || BR2_sh2a_nofpueb || BR2_sh2eb || \
- BR2_sh3eb || BR2_sh4eb || BR2_sparc || BR2_sparc64
+ BR2_sh3eb || BR2_sh4eb || BR2_sparc
config BR2_TARGET_ROOTFS_JFFS2_LE
bool "little-endian"
diff --git a/package/liboil/liboil.mk b/package/liboil/liboil.mk
index 1bb412fc5..44017bed6 100644
--- a/package/liboil/liboil.mk
+++ b/package/liboil/liboil.mk
@@ -16,9 +16,6 @@ LIBOIL_INSTALL_TARGET = YES
ifeq ($(BR2_avr32),y)
LIBOIL_CONF_ENV = as_cv_unaligned_access=no
endif
-ifeq ($(BR2_cris),y)
-LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
-endif
ifeq ($(BR2_x86_64),y)
LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
endif
diff --git a/package/ltrace/Config.in b/package/ltrace/Config.in
index 10a0e0aa5..9e71d827a 100644
--- a/package/ltrace/Config.in
+++ b/package/ltrace/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_LTRACE
bool "ltrace"
- depends on !(BR2_avr32 || BR2_cris || BR2_mips || BR2_mipsel || BR2_sh || BR2_sh64 || BR2_xtensa)
+ depends on !(BR2_avr32 || BR2_mips || BR2_mipsel || BR2_sh || BR2_sh64 || BR2_xtensa)
select BR2_PACKAGE_LIBELF
help
Debugging program which runs a specified command until it exits.
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index edbfe8b4f..22b14f255 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -11,9 +11,6 @@ OPENSSL_DEPENDENCIES = zlib
OPENSSL_TARGET_ARCH=generic32
# Some architectures are optimized in OpenSSL
-ifeq ($(ARCH),ia64)
-OPENSSL_TARGET_ARCH=ia64
-endif
ifeq ($(ARCH),powerpc)
OPENSSL_TARGET_ARCH=ppc
endif
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 70d8de9db..760bb9823 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -93,7 +93,7 @@ config BR2_GCC_SHARED_LIBGCC
bool "Build/install a shared libgcc?"
depends on !BR2_PREFER_STATIC_LIB
default y
- depends on !BR2_sparc && !BR2_sparc64
+ depends on !BR2_sparc
help
Build/install a shared libgcc library
diff --git a/toolchain/toolchain-common.in b/toolchain/toolchain-common.in
index ea06acefa..f67c30aa5 100644
--- a/toolchain/toolchain-common.in
+++ b/toolchain/toolchain-common.in
@@ -9,7 +9,6 @@ comment "Common Toolchain Options"
config BR2_LARGEFILE
bool "Enable large file (files > 2 GB) support?"
- depends on !BR2_cris
help
If you are building your own toolchain and you want to
support files larger than 2GB then enable this option.