summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2012-02-07 21:51:22 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-02-07 23:30:47 +0100
commit9b9765b8a3dfb1aa2f0f48092df19523aac78f8a (patch)
tree40889110359750fa5520e7cc99fd2af932b5bb53
parentfc09aae5b471980f67bd5b589ab1af3f71014760 (diff)
Add package dstat (python script for system stats/profiling)
[Peter: depend on WCHAR as python needs it, fix white space] Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Config.in1
-rw-r--r--package/dstat/Config.in23
-rw-r--r--package/dstat/dstat.mk15
3 files changed, 39 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 66ee26693..c67965207 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -19,6 +19,7 @@ endmenu
menu "Debugging, profiling and benchmark"
source "package/bonnie/Config.in"
source "package/dhrystone/Config.in"
+source "package/dstat/Config.in"
source "package/dmalloc/Config.in"
source "package/kexec/Config.in"
source "package/lmbench/Config.in"
diff --git a/package/dstat/Config.in b/package/dstat/Config.in
new file mode 100644
index 000000000..1439c8b09
--- /dev/null
+++ b/package/dstat/Config.in
@@ -0,0 +1,23 @@
+config BR2_PACKAGE_DSTAT
+ bool "dstat"
+ depends on BR2_USE_WCHAR # python
+ select BR2_PACKAGE_PYTHON
+ help
+ Dstat, written in Python, is a versatile replacement for vmstat,
+ iostat, netstat and ifstat. Dstat overcomes some of their limitations
+ and adds some extra features, more counters and flexibility. Dstat is
+ handy for monitoring systems during performance tuning tests,
+ benchmarks or troubleshooting.
+ Dstat allows you to view all of your system resources in real-time,
+ you can e.g. compare disk utilization in combination with interrupts
+ from your IDE controller, or compare the network bandwidth numbers
+ directly with the disk throughput (in the same interval).
+
+ Note that to get proper output, your terminal size should be known by
+ the termios subsystem. This can be done by running the 'resize'
+ utility of busybox.
+
+ http://dag.wieers.com/home-made/dstat/
+
+comment "dstat requires a toolchain with WCHAR support"
+ depends on !BR2_USE_WCHAR
diff --git a/package/dstat/dstat.mk b/package/dstat/dstat.mk
new file mode 100644
index 000000000..a19d1d4e2
--- /dev/null
+++ b/package/dstat/dstat.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# dstat
+#
+#############################################################
+
+DSTAT_VERSION = 0.7.2
+DSTAT_SOURCE = dstat-$(DSTAT_VERSION).tar.bz2
+DSTAT_SITE = http://dag.wieers.com/home-made/dstat
+
+define DSTAT_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(call GENTARGETS))