summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2012-02-08 17:22:16 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-02-09 21:45:59 +0100
commita792668b58fd5f551f30d40c2352f16011f1f92f (patch)
treef87f66a0a05c0003fc8aeeeec2e45a0b0bd84c03
parent1e39b8a6ff5ba330688bc1a60d1e509d716b6900 (diff)
dependencies: move from toolchain/ to support/
As suggested by Arnout Vandecappelle, move toolchain/dependencies to support/dependencies, as it really is not toolchain-specific anymore. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--Makefile2
-rw-r--r--support/dependencies/dependencies.mk (renamed from toolchain/dependencies/dependencies.mk)2
-rwxr-xr-xsupport/dependencies/dependencies.sh (renamed from toolchain/dependencies/dependencies.sh)0
-rw-r--r--toolchain/toolchain-buildroot.mk1
-rw-r--r--toolchain/toolchain-crosstool-ng.mk1
-rw-r--r--toolchain/toolchain-external.mk1
6 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index e1621f965..90d1a9d50 100644
--- a/Makefile
+++ b/Makefile
@@ -297,6 +297,8 @@ include package/Makefile.in
all: world
+include support/dependencies/dependencies.mk
+
# We also need the various per-package makefiles, which also add
# each selected package to TARGETS if that package was selected
# in the .config file.
diff --git a/toolchain/dependencies/dependencies.mk b/support/dependencies/dependencies.mk
index ea8bf252b..3e621e9dd 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/support/dependencies/dependencies.mk
@@ -14,7 +14,7 @@ core-dependencies:
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
CONFIG_FILE="$(CONFIG_DIR)/.config" \
DL_TOOLS="$(sort $(DL_TOOLS_DEPENDENCIES))" \
- $(TOPDIR)/toolchain/dependencies/dependencies.sh
+ $(TOPDIR)/support/dependencies/dependencies.sh
dependencies: core-dependencies $(DEPENDENCIES_HOST_PREREQ)
diff --git a/toolchain/dependencies/dependencies.sh b/support/dependencies/dependencies.sh
index c47ffcf43..c47ffcf43 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/support/dependencies/dependencies.sh
diff --git a/toolchain/toolchain-buildroot.mk b/toolchain/toolchain-buildroot.mk
index c61156276..f21cefdb1 100644
--- a/toolchain/toolchain-buildroot.mk
+++ b/toolchain/toolchain-buildroot.mk
@@ -1,6 +1,5 @@
# Include files required for the internal toolchain backend
-include toolchain/dependencies/dependencies.mk
include toolchain/elf2flt/elf2flt.mk
include toolchain/gcc/gcc-uclibc-4.x.mk
include toolchain/gdb/gdb.mk
diff --git a/toolchain/toolchain-crosstool-ng.mk b/toolchain/toolchain-crosstool-ng.mk
index e480da981..f6cc2b917 100644
--- a/toolchain/toolchain-crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng.mk
@@ -2,7 +2,6 @@
# Explicit ordering:
include toolchain/helpers.mk
-include toolchain/dependencies/dependencies.mk
include toolchain/elf2flt/elf2flt.mk
include toolchain/gcc/gcc-uclibc-4.x.mk
include toolchain/gdb/gdb.mk
diff --git a/toolchain/toolchain-external.mk b/toolchain/toolchain-external.mk
index d67405b00..d5b2aacbd 100644
--- a/toolchain/toolchain-external.mk
+++ b/toolchain/toolchain-external.mk
@@ -1,7 +1,6 @@
# Required includes for the external toolchain backend
include toolchain/helpers.mk
-include toolchain/dependencies/dependencies.mk
include toolchain/elf2flt/elf2flt.mk
include toolchain/gcc/gcc-uclibc-4.x.mk
include toolchain/gdb/gdb.mk